activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dejan Bosanac <de...@nighttale.net>
Subject Re: Load testing 5.5 - broker pauses between sends
Date Mon, 01 Aug 2011 15:27:32 GMT
Hi,

what I noticed is that you are using VM Cursor for the test.queue.

That means that messages will be queued until there's enough memory for the
broker. You should use default store based cursor for your use case to work
properly.


Regards
-- 
Dejan Bosanac - http://twitter.com/dejanb
-----------------
The experts in open source integration and messaging - http://fusesource.com
ActiveMQ in Action - http://www.manning.com/snyder/
Blog - http://www.nighttale.net


On Mon, Aug 1, 2011 at 2:46 PM, Joe Smith <joesmithcomm@yahoo.com> wrote:

> Another follow-up.  We let the job ran over the weekend.  We kill the
> consumers.  The messages eventually filled up the buffer.  The systemUsage
> is the default (commented out).   Assuming the msg will flow to disk until
> limit.   After we stopped the consumer for 24 hrs, we tried to connect the
> consumers.  The consumers keep getting time out error.  Jconsole and http
> admin won't connect as well.   The broker basically stopped functioning and
> won't accept any connections.  The only thing we could do was to stop and
> re-start the server.
>
> Anyone can provide tips on working around this issue?
>
> Regards

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message