activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Timothy Bish <tabish...@gmail.com>
Subject Re: NMS producer slow
Date Thu, 25 Aug 2011 15:57:07 GMT
On Thu, 2011-08-25 at 08:50 -0700, iceball12 wrote:
> NMS 1.1.0.1642 and activemq 5.4.1
> 

That version of NMS is extrememly old, you'd be wise to update to the
latest release 1.5.1 of the NMS.ActiveMQ lib.

> Sometimes when producer messages to a queue it takes a long time for the
> message is actually enqueued.
> 
> The weird thing is that when i produce multiple messages to the same queue
> quickly then all messages are enqueued quickly
> the Delay is only when 1 message is enqueued and then for a while nothing is
> enqueued.
> 
> I have used default settings for the broker, and no special settings for the
> connectionfactory in nms.
> 
> Also the messages always seem to be consumed by the same consumer, even
> though this queue has 4 consumers, the same one gets all messages.
> Another queue with consumers from the same source does consume evenly over
> the 4 consumer per queue.
> Might this indicate some problem with either the queue or the broker
> settings?
> Is there anything that could force delay in enqueuing but does enqueue quick
> for more then 1 message in a short period of time?
> 

If producer flow control is enabled and your queue is not being drained
fast enough then it could affect the producer.  You can lower the
prefetch value for the consumers so that the messages are spread evenly
amongst them, try using a value of 1 for prefetch.

Regards

-- 
Tim Bish
------------
FuseSource
Email: tim.bish@fusesource.com
Web: http://fusesource.com
Twitter: tabish121
Blog: http://timbish.blogspot.com/




Mime
View raw message