activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From guerra <jg.gue...@gmail.com>
Subject ActiveMQ client can't resume connections after re-deploy on GF 3.1
Date Wed, 10 Aug 2011 11:47:27 GMT
Hi
I came across with a problem using an activemq client deployed in a webapp
on GF 3.1.

For some reason, when the application is redeployed or reloaded, the client
isn't able to re-open the connection against the broker. Once the
application gets this state, the only way to reconnect the application is
restarting the server. I am not sure whether the problem is on the glassfish
classloader or Activemq. 

I've attached the exception thrown by the webapp. I'd be pleased if anyone
here can shed some light on this problem.

Thanks.

11:20:28.571 [pool-38-thread-24] INFO  t.n.a.c.f.NTCSActiveMQTelemetryClient
- ActiveMQ Telemetry client is about to connect with broker
failover:(tcp://tcs-
amq-dev:40300)
11:20:28.572 [pool-38-thread-24] ERROR t.n.a.c.f.NTCSActiveMQTelemetryClient
- Telemetry client can't create ActiveMQ connection
failover:(tcp://tcs-amq-dev:
40300).{}
11:20:28.573 [pool-38-thread-24] ERROR t.n.a.c.f.NTCSActiveMQTelemetryClient
- Exception {}
javax.jms.JMSException: Could not create Transport. Reason:
java.io.IOException: Transport scheme NOT recognized: [failover]
        at
org.apache.activemq.util.JMSExceptionSupport.create(JMSExceptionSupport.java:35)
~[activemq-core-5.5.0.jar:5.5.0]
        at
org.apache.activemq.ActiveMQConnectionFactory.createTransport(ActiveMQConnectionFactory.java:245)
~[activemq-core-5.5.0.jar:5.5.0]
        at
org.apache.activemq.ActiveMQConnectionFactory.createActiveMQConnection(ActiveMQConnectionFactory.java:258)
~[activemq-core-5.5.0.jar:5.5.0]
        at
org.apache.activemq.ActiveMQConnectionFactory.createActiveMQConnection(ActiveMQConnectionFactory.java:230)
~[activemq-core-5.5.0.jar:5.5.0]
        at
org.apache.activemq.ActiveMQConnectionFactory.createConnection(ActiveMQConnectionFactory.java:178)
~[activemq-core-5.5.0.jar:5.5.0]
        at
tng.ntcs.activemq.client.factory.NTCSActiveMQTelemetryClient$ConnectCommand.call(NTCSActiveMQTelemetryClient.java:273)
[ntcs-activemqclient-1.0M2b
2.jar:na]
        at
tng.ntcs.activemq.client.factory.NTCSActiveMQTelemetryClient$ConnectCommand.call(NTCSActiveMQTelemetryClient.java:1)
[ntcs-activemqclient-1.0M2b2.
jar:na]
        at
java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
[na:1.6.0_24]
        at java.util.concurrent.FutureTask.run(FutureTask.java:138)
[na:1.6.0_24]
        at java.lang.Thread.run(Thread.java:662) [na:1.6.0_24]
Caused by: java.io.IOException: Transport scheme NOT recognized: [failover]
        at
org.apache.activemq.util.IOExceptionSupport.create(IOExceptionSupport.java:27)
~[activemq-core-5.5.0.jar:5.5.0]
        at
org.apache.activemq.transport.TransportFactory.findTransportFactory(TransportFactory.java:204)
~[activemq-core-5.5.0.jar:5.5.0]
        at
org.apache.activemq.transport.TransportFactory.connect(TransportFactory.java:79)
~[activemq-core-5.5.0.jar:5.5.0]
        at
org.apache.activemq.ActiveMQConnectionFactory.createTransport(ActiveMQConnectionFactory.java:243)
~[activemq-core-5.5.0.jar:5.5.0]
        ... 8 common frames omitted
Caused by: java.lang.IllegalStateException: WEB9031: WebappClassLoader
unable to load resource
[META-INF/services/org/apache/activemq/transport/failover], because it has
not yet been started, or was already stopped
        at
org.glassfish.web.loader.WebappClassLoader.findResourceInternal(WebappClassLoader.java:2074)
~[war-util.jar:3.1]
        at
org.glassfish.web.loader.WebappClassLoader.findResource(WebappClassLoader.java:1034)
~[war-util.jar:3.1]
        at
org.glassfish.web.loader.WebappClassLoader.findResource(WebappClassLoader.java:1018)
~[war-util.jar:3.1]
        at
org.glassfish.web.loader.WebappClassLoader.getResourceAsStream(WebappClassLoader.java:1263)
~[war-util.jar:3.1]
        at
org.apache.activemq.util.FactoryFinder$StandaloneObjectFactory.loadProperties(FactoryFinder.java:92)
~[activemq-core-5.5.0.jar:5.5.0]
        at
org.apache.activemq.util.FactoryFinder$StandaloneObjectFactory.create(FactoryFinder.java:58)
~[activemq-core-5.5.0.jar:5.5.0]
        at
org.apache.activemq.util.FactoryFinder.newInstance(FactoryFinder.java:146)
~[activemq-core-5.5.0.jar:5.5.0]
        at
org.apache.activemq.transport.TransportFactory.findTransportFactory(TransportFactory.java:201)
~[activemq-core-5.5.0.jar:5.5.0]
        ... 10 common frames omitted


--
View this message in context: http://activemq.2283324.n4.nabble.com/ActiveMQ-client-can-t-resume-connections-after-re-deploy-on-GF-3-1-tp3732697p3732697.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message