activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dejan Bosanac <de...@nighttale.net>
Subject Re: Possible memory leak
Date Wed, 13 Jul 2011 14:11:06 GMT
Hi,

can you test the latest release 5.5.0 (or the latest 5.6-SNAPSHOT) and
confirm that problem still exists?

Regards
-- 
Dejan Bosanac - http://twitter.com/dejanb
-----------------
The experts in open source integration and messaging - http://fusesource.com
ActiveMQ in Action - http://www.manning.com/snyder/
Blog - http://www.nighttale.net


On Wed, Jul 13, 2011 at 3:56 PM, Simon-Pierre LeBel <splebel@iweb.com>wrote:

> Hi,
>
> I have the following setup:
> - ActiveMQ 5.3.2
> - Pure Master/Slave
> - ~800 consumers
> - ~320 queues
> - ~650 topics
>
> My monitoring shows that the memory usage is going up daily, in 5 days
> the heap used went up by 50MB without any changes in consumers, queues
> or topics count. I tried to force GC but the memory usage doesn't go
> down which is probably caused by a memory leak.
>
> I've attached screenshots of heap profiling done with MAT, the first one
> was done on monday, the second today. The biggest difference between the
> two days is org.apache.activemq.openwire.OpenWireFormat memory usage.
>
> Can you help me identify the cause and fix this issue ?
>
> Let me know if you need more informations.
>
> Regards,
>
> --
> Simon-Pierre LeBel [iWeb]
> IT Architecture Specialist / Technical Lead
> Sp├ęcialiste de l'Architecture TI / Leader Technique
> http://www.iWeb.com/
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message