activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Fletcher <fletch...@gmail.com>
Subject Simplest possible broker-to-broker authentication
Date Tue, 05 Jul 2011 09:28:07 GMT
I'm trying to implement security and I want to start by just creating a
simple broker to broker authentication (ActiveMQ 5.5.0). Unfortunately when
I add the simpleAuthenticationPlugin to one broker, it throws WARN messages,
even when it is the only thing running (nothing trying to connect to it):

2011-07-05 11:18:10,346 | WARN  | Failed to add Connection
ID:JOHN-PC-49383-13023852174556-0:825, reason: java.lang.SecurityException:
User name or password is invalid. |
org.apache.activemq.broker.TransportConnection | ActiveMQ Transport: tcp:///
127.0.0.1:51042
2011-07-05 11:18:15,348 | INFO  | Transport failed: java.io.EOFException |
org.apache.activemq.broker.TransportConnection.Transport | ActiveMQ
Transport: tcp:///127.0.0.1:51042

 I read that this could be because of other activemq components so I tried
to make the simplest config file possible, but the same problem persists:

<beans
  xmlns="http://www.springframework.org/schema/beans"
  xmlns:amq="http://activemq.apache.org/schema/core"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://www.springframework.org/schema/beans
http://www.springframework.org/schema/beans/spring-beans-2.0.xsd
  http://activemq.apache.org/schema/core
http://activemq.apache.org/schema/core/activemq-core.xsd">
    <broker xmlns="http://activemq.apache.org/schema/core"
brokerName="localhost" dataDirectory="${activemq.base}/data"
destroyApplicationContextOnStop="true">
        <plugins>
          <simpleAuthenticationPlugin>
            <users>
              <authenticationUser username="system" password="manager"
                  groups="users,admins"/>
            </users>
          </simpleAuthenticationPlugin>
        </plugins>

        <transportConnectors>
            <transportConnector name="openwire" uri="tcp://0.0.0.0:61616"/>
        </transportConnectors>
    </broker>
</beans>

How can I get the simpleAuthenticationPlugin going?

John

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message