activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dejan Bosanac <de...@nighttale.net>
Subject Re: Logging configuration errors during startup
Date Fri, 24 Jun 2011 12:38:31 GMT
BTW. you need to set trashold for the console logger to debug as well

Regards
-- 
Dejan Bosanac - http://twitter.com/dejanb
-----------------
The experts in open source integration and messaging - http://fusesource.com
ActiveMQ in Action - http://www.manning.com/snyder/
Blog - http://www.nighttale.net


On Fri, Jun 24, 2011 at 2:33 PM, Gary Tully <gary.tully@gmail.com> wrote:

> ./activemq console ....
>
> with that flag it will run in the foreground and output to the console.
>
> On 24 June 2011 09:46, Tom <808131@gmail.com> wrote:
> > On 23 Jun 2011 12:41, "Dejan Bosanac" <dejan@nighttale.net> wrote:
> >>
> >> Sure, ActiveMQ uses Spring to load the configuration, so just set
> >> "org.springframework" logger to desired level.
> > That's what I am saying though - I have everything at DEBUG and still
> don't
> > see any logging. It seems that Spring Exceptions bubble up all the way to
> >
> >
> org.apache.activemq.console.command.StartCommand.runTask(StartCommand.java:99)
> >
> > and the only place they go are STDOUT.
> > STDOUT is redirected to /dev/null in the activemq startup script which is
> > why I get nothing. I can't tell from the source whether there is
> additional
> > configuration required but it would be nice for errors to be very obvious
> > out-of-the-box.
> >
> > Regards,
> > Tom
> >
> >
> >>
> >> Regards
> >> --
> >> Dejan Bosanac - http://twitter.com/dejanb
> >> -----------------
> >> The experts in open source integration and messaging -
> > http://fusesource.com
> >> ActiveMQ in Action - http://www.manning.com/snyder/
> >> Blog - http://www.nighttale.net
> >>
> >>
> >> On Thu, Jun 23, 2011 at 12:48 PM, Tom <808131@gmail.com> wrote:
> >>
> >> > Hi,
> >> >
> >> > Is there any way to get more verbose logging of errors when activemq
> > reads
> >> > its config file? For example, simply adding a random character to
> break
> > the
> >> > XML will mean that activemq dies silently on startup with no error
> > message
> >> > in ../data/activemq.log
> >> > It feels like I've missed something really obvious - I've already
> > enabled
> >> > full DEBUG and the last line is always....
> >> >
> >> > 2011-06-23 11:28:37,020 | DEBUG | Found XML schema [
> >> > http://activemq.apache.org/schema/core/activemq-core.xsd] in
> classpath:
> >> > activemq.xsd |
> >> > org.springframework.beans.factory.xml.PluggableSchemaResolver
> >> > | main
> >> >
> >> > I'm using activemq 5.5.0
> >> >
> >> > Regards,
> >> > Tom
> >> >
> >
>
>
>
> --
> http://fusesource.com
> http://blog.garytully.com
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message