activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Tully <gary.tu...@gmail.com>
Subject Re: Messages getting stuck on one broker
Date Thu, 23 Jun 2011 16:10:15 GMT
This is a known issue: https://issues.apache.org/jira/browse/AMQ-2324
but I think this should be configurable, at least it should be
possible to allow resending back to the origin broker when there are
no local consumers.  There are issues with duplicate detection in the
cursors but otherwise it should be ok. I am working on a solution to
this.

The failover updateClusterClients feature helps to rebalance consumers
when a network broker is restarted, so this helps to some extent.
http://activemq.apache.org/failover-transport-reference.html

On 14 June 2011 15:37, dburke <dburke@addictmud.org> wrote:
> Never mind, I found out that this is technically by design.  Apparently
> messages don't return to brokers that they've already been to, by tagging
> the message with broker id's that it's been to.  Sounds to me like this is
> to prevent looping and what-not, because of all the fancy routing you can do
> with AMQ.
>
> Now that I know that, I've started some design changes to our setup to
> accommodate.
>
> Dan.
>
>
> --
> View this message in context: http://activemq.2283324.n4.nabble.com/Messages-getting-stuck-on-one-broker-tp3589529p3596741.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>



-- 
http://fusesource.com
http://blog.garytully.com

Mime
View raw message