activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "qinding1@yahoo.com" <qindi...@yahoo.com>
Subject RE: statisticsBrokerPlugin with Camel in Servicemix
Date Fri, 03 Jun 2011 23:16:34 GMT

Sent from my LG phone

john <john.fansler@ateb.com> wrote:

>Yes, I tried going to ActiveMQ.Statistics.Broker. I assume that using
>the <inOut> in Camel takes care of setting the replyTo.
>
> 
>
>I finally created a unit test to run. This led to realize that it
>doesn't look like I get a statistics for a queue response back if no
>messages have been sent to the queue or if there is not a Camel consumer
>for the given queue. I've moved over to using the Broker statistics as
>you suggest while I get the route straight.
>
> 
>
>I'm now to the point that I'm trying to use the same code from my
>working unit test in my servicemix deployed app. Even with working xml
>route moved from the unit test to my bundle I get the Camel timeout on a
>response.
>
> 
>
>Is there a way to query activemq to ensure that my configuration change
>to the activemq.xml file which includes the statistics plugin took?
>
> 
>
>That configuration the only difference I can think of between my unit
>test and the deployed app.
>
> 
>
>Thanks,
>
> 
>
>-john
>
> 
>
>From: Rob Davies [via ActiveMQ]
>[mailto:ml-node+3570197-78408851-242274@n4.nabble.com] 
>Sent: Friday, June 03, 2011 3:37 AM
>To: John Fansler
>Subject: Re: statisticsBrokerPlugin with Camel in Servicemix
>
> 
>
>have you tried sending a message to ActiveMQ.Statistics.Broker - to see
>if you get a response (you need to set the replyTo destination on the
>message) ? 
>
>On 2 Jun 2011, at 21:13, john wrote: 
>
>
>> I'm running the fuse 4.2.0-fuse-02-00 release. 
>> 
>> It includes activemq 5.3.1 along with Camel 2.2 all running in
>ServiceMix. 
>> 
>> The two work great together, but now I'm trying to use the 
>> statisticsBrokerPlugin to query the number of messages on a queue. 
>> 
>> I've attempted this several different ways in Camel, finally falling
>back to 
>> the example route in the ActiveMQ in Action book but I still can't get
>a 
>> response from the plugin. I have updated the activemq.xml file to
>include 
>> the plugin. 
>> 
>> Every time I send a message to the statistics queue, I get an error
>because 
>> the Camel route does not get a response within 20 seconds. 
>> 
>> Any help on how to determine whether the plugin is really active or
>how to 
>> trace where things are falling apart is appreciated. 
>> 
>> Thanks! 
>> 
>> -john 
>> 
>> -- 
>> View this message in context:
>http://activemq.2283324.n4.nabble.com/statisticsBrokerPlugin-with-Camel-
>in-Servicemix-tp3569286p3569286.html
>> Sent from the ActiveMQ - User mailing list archive at Nabble.com. 
>
>
>
>
>
>________________________________
>
>If you reply to this email, your message will be added to the discussion
>below:
>
>http://activemq.2283324.n4.nabble.com/statisticsBrokerPlugin-with-Camel-
>in-Servicemix-tp3569286p3570197.html 
>
>To unsubscribe from statisticsBrokerPlugin with Camel in Servicemix,
>click here
><http://activemq.2283324.n4.nabble.com/template/NamlServlet.jtp?macro=un
>subscribe_by_code&node=3569286&code=am9obi5mYW5zbGVyQGF0ZWIuY29tfDM1Njky
>ODZ8NDMzMDUyNDYz> . 
>
>
>
>--
>View this message in context: http://activemq.2283324.n4.nabble.com/statisticsBrokerPlugin-with-Camel-in-Servicemix-tp3569286p3571126.html
>Sent from the ActiveMQ - User mailing list archive at Nabble.com.
Mime
View raw message