activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yuvaraj Vanarase <yuvaraj.vanar...@synechron.com>
Subject Dynamic Queue Creation Issue
Date Tue, 07 Jun 2011 10:21:32 GMT
Hi,

I am creating queues dynamically(as of now testing with 2 only). Every time I create new connection
at sender side (connection->session->queue->sender) and also new connection to create
message listeners. Creation of 2 queues happens 1 minute interval.
I could see that for first queue messages are correctly enqueued and also dequeued. However
for 2nd queue, messages are correctly enqueued however not a single message is dequeued. I
do see the consumers though.

More details:

-          I am using non transacted session only.

-          No any exception in activemq.log file

-          Using Jboss (MQ is not embeded), no exception on jboss

-          Well, I earlier used to close sender side connection once sending finishes, however
guessing that might be causing some issue, I do not close any connections established

-          First queue consumers also do not pickup messages after some time, so first queue
does also have few pending messages

Any pointers would be helpful?

Regards,
Yuvaraj

Yuvaraj Vanarase,
Lead Technology - Software
Phone: +91.20.40262000 Ext 2305|Mobile: +91.9850818870 | http://www.synechron.com
SYNECHRON -
- Top 10 Best IT Employers for 4 consecutive years (link<http://www.synechron.com/news/news_best_employer_sep2010.htm>).
- Celebrating 10 Years!


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message