activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From dburke <dbu...@addictmud.org>
Subject Messages getting stuck on one broker
Date Fri, 10 Jun 2011 22:52:30 GMT
Hello,

I'm trying to setup a "network of brokers".  In our dev and staging
environment I'm setting up two ActiveMQ servers, but in production there
will be at least four.

What I'm finding problematic is this...

The producer pushes messages to Broker1.  If there are no consumers on
Broker1, the messages get moved to Broker2, and the consumer gets these
messages.

But... if the consumer disconnects, and reconnects to Broker1, any messages
on Broker2 are never moved to Broker1.

Everything is written in perl, so I'm using Net::Stomp, but I assume that
it's not much of a factor here.

I am using the activemq-stomp.xml config, so I worry what's missing.

Not using persistence, but eventually we will want to.

I also wonder if it's just that I don't have the broker's setup right to
'network'.

This is the config I found, and tried to tweak to setup the 'network of
brokers'


        <networkConnectors>
                <networkConnector uri="multicast://default" duplex="true"
networkTTL="1000" dynamicOnly="true" />
        </networkConnectors>

        <transportConnectors>
            <transportConnector name="stomp"
uri="stomp://0.0.0.0:61612?transport.closeAsync=true;useQueueForAccept=false;maximumConnections=9999"/>
            <transportConnector name="stomp+nio"
uri="stomp+nio://0.0.0.0:61613?transport.closeAsync=true;useQueueForAccept=false;maximumConnections=9999"/>

            <transportConnector uri="tcp://0.0.0.0:0"
discoveryUri="multicast://default"/>

        </transportConnectors>

Any help to iron out this issue would be greatly appreciated.  This was a
hard sell to my boss to use ActiveMQ (well, any messaging server really),
but the benefits we're expecting to see are enormous, and we're getting
really close to going live, but this is going to be a show stopper, because
we're setting too many clients stop dead because their messages aren't on
their broker :(

Thanks in advance!
Dan.


--
View this message in context: http://activemq.2283324.n4.nabble.com/Messages-getting-stuck-on-one-broker-tp3589529p3589529.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message