activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From KRISHNADASANTS <krishnadasa...@geojit.com>
Subject Message stuck on queue(Production Issue)
Date Fri, 10 Jun 2011 06:20:00 GMT
hi,

message sent by a particular producer(web application) is stuck for some
time (20 to 40 sec) in the queue.After a delay it is consumed.It is
happening in our production system we can not reproduce it in development.
producer is using fail-over tcp transport.messages sent by other producers
in the same queue is consumed by the same consumer immediately. when we
monitor with jmx console the message is coming in to the queue immediately
on publish from the producer. but it stays there for some 20 to 40 seconds
and then consumed by consumer.Interesting thing we see is. if we use the
browse message function from jmx console immediately that message is
consumed by the consumer.And one more thing we noticed is that when another
message comes from the same producer then the old message will immediately
consumed.

   We are using activemq 5.4.2. This is not happening always. I thing after
some events it is happening like that.once it is happened, then this
behavior will continue till broker restart.  after monitoring in production
for two days  i can give some events that may be the reason for this(but we
could not reproduce it in development).

first day
 Message sending from our web application was fast(continually on that full
day)
 after 9 pm to next day morning there was no activities in web application (
chance of connection timeout but we are using fail over transport)
Next Day
  morning we stopped consumer application  (for daily db initialization
work),web application is not restarted.
  at that time some request was fired by web application 
  when we started consumer application this pending requests were received
  from next live request onwards the message consumption is getting delayed
  but messages from our thick client in same queue is consumed by the same
consumer within milliseconds.


I hope you people will get any clue from this events described.I also tried
with useCache=false setting( as per some post in this forum for a similar
problem). But  then the same problem also continued after broker restart
also.when i remove that and restarted the broker the problem get solved. 

since this is a production issue i need your urgent help.

Thanks 
Krishnadasan T S

--
View this message in context: http://activemq.2283324.n4.nabble.com/Message-stuck-on-queue-Production-Issue-tp3587653p3587653.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message