activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Tully <gary.tu...@gmail.com>
Subject Re: activemqrc in user's home dir not being used?
Date Tue, 31 May 2011 15:54:50 GMT
yep, that is a known issue that is resolved on trunk.
http://svn.apache.org/viewvc?view=revision&revision=1088989

The ACTIVEMQ_OPTS var was evaluated before sourcing the user env.

The current trunk version of the script will work as expected:

http://svn.apache.org/viewvc/activemq/trunk/assembly/src/release/bin/activemq?view=markup


On 31 May 2011 15:49, Tommy Chheng <tommy.chheng@gmail.com> wrote:
> I'm using activemq 5.5 and the .activemqrc file is not being used.
>
> In the .activemqrc, I change the default MEMORY+OPTS env variables.
> # Set jvm memory configuration
> ACTIVEMQ_OPTS_MEMORY="-Xms512M -Xmx1024M"
>
> if [ -z "$ACTIVEMQ_OPTS" ] ; then
> ACTIVEMQ_OPTS="$ACTIVEMQ_OPTS_MEMORY -Dorg.apache.activemq.UseDedicatedTaskRunner=false
-Djava.util.logging.config.file=logging.properties"
> fi
>
> I start activemq and it states it's using the .activemqrc file:
> $ACTIVEMQ_HOME/bin/activemq start xbean:file:/opt/activemq/conf/activemq.xml
> INFO: Loading '/home/deploy/.activemqrc'
> INFO: Using java '/usr/lib/jvm/java-6-openjdk/bin/java'
> INFO: Starting - inspect logfiles specified in logging.properties and log4j.properties
to get details
>
>
> But when I take a look at the process, it's using the default parameters:
> deploy 9467 2.4 6.2 427188 108956 pts/1 Sl 14:37 0:02 /usr/lib/jvm/java-6-openjdk/bin/java
-Xms256M -Xmx256M -Dorg.apache.activemq.UseDedicatedTaskRunner=true -Djava.util.logging.config.file=logging.properties
.....
>
>
> --
> Tommy Chheng
> @tommychheng
> http://tommy.chheng.com



-- 
http://fusesource.com
http://blog.garytully.com

Mime
View raw message