activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Tully <gary.tu...@gmail.com>
Subject Re: problem building using activemq 5.5.0 core using maven
Date Wed, 11 May 2011 15:24:17 GMT
eclipse has its own embedded maven build so it may behave differently.
5.5 requires jdk 1.6 to build in any event.

On 11 May 2011 16:00, jthomas@manhattansoftware.com
<jthomas@manhattansoftware.com> wrote:
> I'm trying to run a JDK 1.5 build using activemq-core-5.5.0.jar.  When I run
> mvn compile, I get the following error which indicates that activemq was
> built using JDK 1.6.  What's odd, is that when I compile using Eclipse,
> there is no problem and I'm performing a JDK 1.5 build there as well.
>
>
> 18\archive\com.manhattansoftware.csadmin\csadmin\1.0-SNAPSHOT\pom.xml
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] BUILD FAILURE
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Compilation failure
> C:\hudson\jobs\csadmin\workspace\trunk\src\main\java\com\manhattan\admin\ActiveMqConnectionPoolHandler.java:[14,-1]
> cannot access org.apache.activemq.jndi.JNDIReferenceFactory
> bad class file:
> C:\apache-maven-local-repository\org\apache\activemq\activemq-core\5.5.0\activemq-core-5.5.0.jar(org/apache/activemq/jndi/JNDIReferenceFactory.class)
> class file has wrong version 50.0, should be 49.0
>
> --
> View this message in context: http://activemq.2283324.n4.nabble.com/problem-building-using-activemq-5-5-0-core-using-maven-tp3514964p3514964.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>



-- 
http://blog.garytully.com
http://fusesource.com

Mime
View raw message