activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From danieldestro <danieldes...@gmail.com>
Subject Slave of ActiveMQ Cluster does not dequeue messages
Date Tue, 10 May 2011 21:52:08 GMT
Hello All.

Just downloaded ActiveMQ 5.4.2 and tested its cluster mode on my development
workstation (PC with Ubuntu Linux 10.04) and it worked fine. Configured
Master to port 61616 and console to port 8161. Slave configured to port
62626 and console to 8262. Both on the same IP.

I tested all possible scenarios I can imagine and it worked fine with a Java
JMS Queue producer / consumer.

Installed (unziped) ActiveMQ 5.4.2 to my production server and configured
(activemq.xml) Master on IP 10.198.14.115, port 61616 and console to 8161
(actually I left as default and changed brokerName="APP-004"). The slave
node is installed on IP 10.198.14.57, port 61616 and console port 8161.
Changed a few things on activemq.xml:

<broker ... brokerName="APP-008" destroyApplicationContextOnStop="true"
masterConnectorURI="tcp://10.198.14.115:61616"
shutdownOnMasterFailure="false">

First I start Master node and it works fine. All Java apps can post /
consume messages from different queues.

When I start Slave node I get no error or warn messages. But when I view the
queues in the web console, the "Number Of Pending Messages" always increase
and never decreases. "Messages Dequeued" are always on ZERO.

Tried to change Slave port to 62626 and nothing changed.

I am afraid if master goes down, the messages will be processed again by the
Slave node. I could not reproduce this scenario in my workstation. Also this
does not seem to be right for me. Slave should increase "messages dequeued"
as master processes them, right???

What can I do to see what is going on?

Thanks

--
View this message in context: http://activemq.2283324.n4.nabble.com/Slave-of-ActiveMQ-Cluster-does-not-dequeue-messages-tp3513100p3513100.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message