activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "tkasireddy@gmail.com" <tkasire...@gmail.com>
Subject Pure Master/Slave config. Synchronization of messages?
Date Mon, 11 Apr 2011 18:58:21 GMT
Hi,

I successfully configured the master and slave. When I shut down the master,
I see error :
java.io.EOFException
        at java.io.DataInputStream.readInt(DataInputStream.java:375)
        at
org.apache.activemq.openwire.OpenWireFormat.unmarshal(OpenWireFormat.
java:269)
        at
org.apache.activemq.transport.tcp.TcpTransport.readCommand(TcpTranspo
rt.java:227)
        at
org.apache.activemq.transport.tcp.TcpTransport.doRun(TcpTransport.jav
a:219)
        at
org.apache.activemq.transport.tcp.TcpTransport.run(TcpTransport.java:
202)
        at java.lang.Thread.run(Thread.java:662)
. 

Also, the admin console doesn't show for the slave. I have no way to check
whether the synchronization of messages is happening or not.

The configuration xml for Master:

   
 
        
            
              
                " producerFlowControl="true" memoryLimit="1mb">
                  
                    
                  
                
                " producerFlowControl="true" memoryLimit="1mb">
                
              
            
         
     
            
        

        
            
        
        
        
            
        

    

    
    
 
Configuration for Slave:


 
   
  
 
   
  
  
  
  

Please help me set it up correctly.

Thanks,
Thirumal.

--
View this message in context: http://activemq.2283324.n4.nabble.com/Pure-Master-Slave-config-Synchronization-of-messages-tp3442845p3442845.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message