activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From nnprasad <>
Subject Re: Messages stuck in queue
Date Thu, 07 Apr 2011 15:15:21 GMT
Hi Gary,

I am trying my level best to give you right inputs.

Please go through the below link where at the last I provided a scenario


when that scenario was happening I captured the log and here it is..


And some one explained their inability to create good test case BUT provided
some thing for this in an issue 


and as you said, I already tried (though when this issue happened, I was
monitoring JCONSOLE memory graph and found good, no high memory usages.)with
increasing memory limit to 1GB from 512MB but in vain. (But I did not tried
removing memory does AMQ handle with no memory specified?)

in the issue I provided
attachments and some useful links which talks about this issue.

I am sure there is no Exceptions logged in activemq logs even with debug
level..Even in Application's Spring  Logs there were no exceptions except
that a message "No message received since xxxxx sec".

When this is happening I ran a separate test (simple JMS/No Spring API)
program and hit that queue (even created a new queue in that activemq). My
test consumer is waiting to receive a message. by this we can say no
suspectable issue with Springs JMS framework API.

Hope I gave sufficient inputs on this issue, when ever I saw a post all
these times. But I will still try for  the best.

Thank You,

View this message in context:
Sent from the ActiveMQ - User mailing list archive at

View raw message