activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael La Budde <patzer...@hotmail.com>
Subject RE: network of broker stop forwarding messages without advisorySupport enabled
Date Fri, 18 Mar 2011 21:35:33 GMT

I believe dynamic broker network topologies require advisorySupport to be enabled; as you
can see here:

http://activemq.apache.org/advisory-message.html


> Date: Thu, 17 Mar 2011 21:18:31 -0700
> To: users@activemq.apache.org
> Subject: network of broker stop forwarding messages without advisorySupport enabled
> 
> I have setup network of brokers exactly as per this post of Bruce Snyder:
> http://bsnyderblog.blogspot.com/2010/01/how-to-use-automatic-failover-in.html:
> 
> Broker 1:
> 
> 
> Broker 2:
> 
> 
> I have advisorySupport="false" in the broker tag of both the amq*.xml and
> started all the brokers.
> 
> Then I started the consumer using command:
> ant consumer -Durl=tcp://0.0.0.0:61616
> and finally started producer using this command:
> ant producer -Durl=tcp://0.0.0.0:61617
> 
> All the produced messaged then go in pending state on the broker running on
> port 61617 and consumer connected on localhost:61616 broker never get the
> messages.
> 
> Does the network of broker stop forwarding messages without advisorySupport
> enabled? I thought that was fixed in recent release. (I'm using activemq
> 5.4.2 release).
> 
> --
> View this message in context: http://activemq.2283324.n4.nabble.com/network-of-broker-stop-forwarding-messages-without-advisorySupport-enabled-tp3386261p3386261.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
 		 	   		  
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message