activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ian Holsman <...@holsman.net>
Subject Re: newbie question about Virtual Topics
Date Tue, 22 Mar 2011 09:41:03 GMT
Thanks Dejan.
changing it to VirtualTopicConsumers.ConsumerNumberOne.VirtualTopic.TEST

worked great.

regards
Ian

On Tue, Mar 22, 2011 at 8:24 PM, Dejan Bosanac <dejan@nighttale.net> wrote:
> Hi,
>
> note that VirtualTopicPubSubUsingXBeanTest, that uses
> global-virtual-topics.xml, uses different pattern for consumer names
>
>    protected String getVirtualTopicConsumerName() {
>        return "VirtualTopicConsumers.ConsumerNumberOne.FOO";
>    }
>
> so you need either to listen to
>
> VirtualTopicConsumers.ConsumerNumberOne.FOO.VirtualTopic.TEST
>
> or leave prefix to default in your broker config.
>
>
> Regards
> --
> Dejan Bosanac
> -----------------
> FuseSource - The experts in open source integration and messaging.
> Email: dejanb@fusesource.com
> Web: http://fusesource.com
> Twitter:  http://twitter.com/dejanb
> ActiveMQ in Action - http://www.manning.com/snyder/
> Blog - http://www.nighttale.net
>
>
> On Tue, Mar 22, 2011 at 9:27 AM, Ian Holsman <ian@holsman.net> wrote:
>
>> Hi.
>> I'm trying to configure a ActiveMQ server to use Virtual Topics.
>>
>> I've copied the broker configuration from
>> https://svn.apache.org/repos/asf/activemq/trunk/activemq-core/src/test/resources/org/apache/activemq/broker/virtual/global-virtual-topics.xml
>>
>> and copied the Test code from the VirtualTopicPubSubTest test case in
>> org.apache.activemq.broker.virtual.
>>
>> but I can't seem to get the consumers to actually receive a message.
>>
>> http://localhost:8161/admin/connections.jsp shows 6 active connections..
>> so I know the thing is connecting and the consumers are listening to 'Queue
>> Consumer.A.VirtualTopic.TEST'
>> (I can also see 4 consumers on http://localhost:8161/admin/queues.jsp )
>>
>> The producer has seemed to send the messages, as I see 10 messages enqueued
>> into VirtualTopic.TEST
>>
>>
>> so I'm not sure what's going on.
>>
>> There are some messages in some of the advisory topics.. but I'm unsure of
>> how to see them.
>>
>> Any pointers to what I'm doing wrong?
>>
>> --
>> Ian Holsman
>> Ian@Holsman.net
>> PH: +1-703 879-3128 AOLIM: ianholsman Skype:iholsman
>>
>> If you can believe in your power to do great things, you will. -- Michael
>> Berg
>>
>>
>

Mime
View raw message