activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nakarikanti, Nageswara" <NNakarika...@dwd.IN.gov>
Subject RE: Message stuck on queue : Same Issue Both 5.2.0 and 5.4.2
Date Tue, 08 Mar 2011 15:58:43 GMT
Hi Gary,

I already  attached some useful resources (.java, .log) and some explanation on some same
issue I found in JIRA.

We can not provide a 100% reproduceable test case as this scenario is not happening always
with a program.

We could not expect when it is really happening (some one posted in the issue - "after some
days of continuous running")

I did hit that queue with my program when it was struck and not releasing messages, the same
happened to my consumer program too.

It didn't get any message. Please have a look at...


Link : https://issues.apache.org/jira/browse/AMQ-1751

Thanking You,
Nag.

-----Original Message-----
From: Gary Tully [mailto:gary.tully@gmail.com] 
Sent: Tuesday, March 08, 2011 6:18 AM
To: users@activemq.apache.org
Subject: Re: Message stuck on queue : Same Issue Both 5.2.0 and 5.4.2

The most important thing for any issue resolution is a good test case that can reproduce the
problematic behavior.
Typically a fix results in a new junit test in activemq-core, so it you can produce a failing
test in that form it would be excellent.
Often, the process of generating a test case; requiring all of the variables to be accessed
and understood can expedite the resolution process by eliminating parts of the system that
just produce noise.

If you can generate such a test, then validate it with the current 5.5-SNAPSHOT, as this contains
all of the known fixes to date.


On 7 March 2011 16:44, nnprasad <NNakarikanti@dwd.in.gov> wrote:
>
> Hi Krishna,
>
> your first post was still pending, hope with no reason
>
> Even I am facing the same Issue, But with ActiveMQ 5.2.0, Windows 2003 
> Server R2 SP2, Persistent with Oracle 10g.
>
> Not you are facing it in Active MQ 5.4.2, I am suggesting an upgrade 
> to my project to 5.4.2 because of this issue.
>
> I am really afraid now. this is going to be a serious problem, as 
> crucial batches are holding on messages for days with no reason because of activeMQ.
>
> I pity myself, no one looked at my POST / Issue created 
> http://activemq.2283324.n4.nabble.com/Strange-Issue-Particular-Queue-N
> ot-sending-Msgs-to-Consumer-td3331634.html
> http://activemq.2283324.n4.nabble.com/Strange-Issue-Particular-Queue-N
> ot-sending-Msgs-to-Consumer-td3331634.html
>
>
> It has been already Late Late Late..we reached 5.4.2
>
> Some one from ActiveMQ must addrres this issue...praying GOD!
>
> Thank You
> NN Prasad
>
> --
> View this message in context: 
> http://activemq.2283324.n4.nabble.com/Message-stuck-on-queue-tp3338786
> p3339422.html Sent from the ActiveMQ - User mailing list archive at 
> Nabble.com.
>



--
http://blog.garytully.com
http://fusesource.com

Mime
View raw message