activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Suneel Papineni" <>
Subject Issues with Network of Brokers, when using multicasr:default
Date Thu, 03 Mar 2011 13:21:33 GMT


I am running ActiveMQ on two systems (using default
activemq-dynamic-network-broker.xml config file). Each one is connected
with one application (which is acting both as a publisher and durable
subscriber) present in that system. A topic "SimpleTopic" is defined and
messages are exchanged properly across the systems.


I am facing problem whenever there is network disconnection or when
Ethernet cable is pulled out from one of the systems (here pulled out
from broker 1). 


When there is disconnection, both brokers notified that other ActiveMQ
is disconnected. During this time I sent some messages from
applications.  Now I tried to reconnect the cable, once it is connected
both ActiveMQ's got updated message that other broker is reconnected.
Same time, all the messages which were sent should be received by the
applications, but this is not happening. Also the messages sent after
reconnection also didn't appear at other party. 


When I checked the logs, I could see a failure message as "Transport
failed: Software caused connection abort: recv
failed". Please find attached logs of each broker.


Could you please help me in resolving this and let me know if there is
any issue or is there anything I am missing.


I tried this with ActiveMQ 5.4.2 and also with 5.5 Snapshot, same issue



Thanks & Regards



Please consider the environment before printing this e-mail
This email and any files transmitted with it are confidential and
intended solely for the use of the individual or entity to whom they
are addressed. If you have received this email in error please notify
the system manager.

Mettoni Ltd
Registered in England and Wales: 4485956
Ashfords House, Grenadier Road, Exeter, EX1 3LH

  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message