activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Pascual <dpascua...@gmail.com>
Subject Re: Apache.NMS.Stomp error receiving special characters
Date Tue, 01 Feb 2011 12:14:18 GMT
I have created the bug in Jira

https://issues.apache.org/jira/browse/AMQNET-315

Thanks for your help

2011/2/1 Timothy Bish <tabish121@gmail.com>

> On Tue, 2011-02-01 at 10:54 +0100, David Pascual wrote:
> > I think text body is encoded  as UTF-8, I have modified the test
> > "TestQueueRollbackConsumerListener" to send the text "Tést Message" and
> when
> > the listener receive the message, the character "é" is illegible. The
> > message is send and recived by Stomp client so the message is processing
> as
> > UTF-8.
> >
> > I have repeated the test reading the message with java client and the
> > special characters are processed without problem, so I think the problem
> is
> > for incoming messages.
> >
> > When a text message is created the only parameter needed is a string and
> in
> > .NET, I think it is encoded as UTF-16. I don't know if this is a problem.
> >
> > Do we have to do something when receive a text message with special
> > characters?
>
> Sounds like a bug, the best thing to do would be to create a new Jira
> issue and attach a unit test that demonstrates the issue.
>
>
> Regards
>
> --
> Tim Bish
> ------------
> FuseSource
> Email: tim.bish@fusesource.com
> Web: http://fusesource.com
> Twitter: tabish121
> Blog: http://timbish.blogspot.com/
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message