activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From konura <aboguslav...@bluecatnetworks.com>
Subject Re: queue still exist even after removal from conf/activemq.xml
Date Fri, 14 Jan 2011 21:45:27 GMT


artnaseef wrote:
> 
> The Logging broker plugin will tell you when a connected client or broker
> creates a destination:
> 
> <broker ...>
> 
> ...
> 
>   <plugins>
>       <loggingBrokerPlugin logInternalEvents="true"
> logConnectionEvents="false"/>
>    </plugins>
> 
> ...
> 
> </broker>
> 
> With this, you will see "Adding destination : ..." messages when
> destinations are created.
> 
> Note that logInternalEvents reduces the logged events; use logAll to get
> everything the plugin has to offer.
> 
> 

Thank you very much, artnaseef!

The problem is solved.
Here is the short summary:

As you advised, I enabled logging, removed kahadb dir and restarted.
These are 2 lines among a lot of others I saw:

2011-01-14 16:31:42,635 | INFO  | Adding destination :
Topic:ActiveMQ.Advisory.Consumer.Queue.pool1_p1_a2 |
org.apache.activemq.broker.util.LoggingBrokerPlugin | ActiveMQ Transport:
tcp:///172.30.208.60:1774
2011-01-14 16:31:42,729 | INFO  | Adding destination :
Topic:ActiveMQ.Advisory.Consumer.Queue.pool1_p1_a2 |
org.apache.activemq.broker.util.LoggingBrokerPlugin | ActiveMQ Transport:
tcp:///172.30.208.60:1774

I immediately spotted the ip address of some server that is not use now, but
it still runs an agent that has pool1_p1_a2 in jndi.properties and trying to
connect to that queue.

Anyway, I killed the agent and the zombie queue vanished!

Thanks again!
-- 
View this message in context: http://activemq.2283324.n4.nabble.com/queue-still-exists-even-after-removal-from-conf-activemq-xml-tp3216681p3218413.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message