activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Reynald Borer <reynald.bo...@gmail.com>
Subject Re: Slow throughput after several hundred messages
Date Wed, 15 Dec 2010 19:30:50 GMT

 Here is a timeline distribution of the GC activity. The period is quite short (a little bit
more that 3 minutes) so it is hard to deduce anything, but here we can see that there is a
period of 30 seconds where the GC activity is more intense, between 45 and 75 seconds. But
all full GC takes around 100ms, so I tend to think that the GC is not the culprit here, it
is only a good indicator of the broker slowdown.


You can try to analyze your GC logs from your production with the GCHisto tool (can be downloaded
here: http://pietrowski.info/wp-content/uploads/2009/06/GCHisto.tgz), maybe it can help in
diagnosing this issue.

Regards,
Reynald



On Tuesday, December 14, 2010 at 14:40 , Robert.Sloss@Misys.com wrote:

> 
> Here is the gc.log and activemq logs, once again taken from a run where I
> allowed it to process, block and then continue processing:
> 
> http://activemq.2283324.n4.nabble.com/file/n3087092/logs_verbose_gc.rar
> logs_verbose_gc.rar 
> 
> -- 
> View this message in context: http://activemq.2283324.n4.nabble.com/Slow-throughput-after-several-hundred-messages-tp3082431p3087092.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
> 
> 
> 
> 




Mime
  • Unnamed multipart/mixed (inline, 8-Bit, 0 bytes)
View raw message