activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Dean <>
Subject Re: Problem with Ajax API
Date Fri, 31 Dec 2010 16:45:53 GMT

On Dec 31, 2010, at 8:04 AM, stratio wrote:

> Updates :
> I tried with dojo and prototype adapters and i have the same problem. It
> works on Chrome and Safari and doesn't on firefox, Opera and even Explorer
> :(
> I really don't know the reason of this behaviour...
> Thanks in advance and happy new year to all :)

I'm really not sure what the problem might be.  It seems you're trying a lot of different
approaches as you look for something which works, and I suspect that a more systematic approach
might be helpful.  Try starting from scratch following the example code exactly as written
in  I believe this will get you a working ajax client.
 You can then start incrementally changing things until you get some code which achieves your
particular purpose.

I can say very confidently that I am able to send and receive messages in FF, Safari, Chrome,
IE7 & IE8 using ActiveMQ 5.4.2.  I receive the "refusing to set unsafe header" error message
in Chrome & Safari, but this doesn't seem to have any meaningful consequences.  (They're
both based on Webkit, so it doesn't surprise me that they both throw this same error message.)

View raw message