activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stan Lewis <sle...@fusesource.com>
Subject Re: Topic messages lost even when they are persistent - help!
Date Fri, 03 Dec 2010 16:45:38 GMT
You need to create the durable subscription *before* sending messages
to the topic, otherwise the broker will drop them regardless if the
messages are marked as persistent or not.  The only way a topic will
store messages is via a durable subscription.

On Fri, Dec 3, 2010 at 10:36 AM, ncsridhar <srn@uc4.com> wrote:
>
> I actually did not run the consumer atleast once on this topic at all. Here
> is what I did:
>
> - I ran a publisher program that put about 10K PERSISTENT msgs on the topic
> - I verified that all 10K msgs are on the topic using admin console
> - I used the activemq admin console that is available at
> http://localhost:8161/admin/index.jsp to create the durable subscriber on
> that topic
> - I restarted the activemq broker and discovered that all messages are lost,
> but the topic itself is there
>
> Where as I put a persistent msg in a "queue" sometime ago and I restarted
> several times after that and the message is still there. So I am not
> understanding where is this going wrong.
>
>
>
> Thanks.
> --
> View this message in context: http://activemq.2283324.n4.nabble.com/Topic-messages-lost-even-when-they-are-persistent-help-tp3069828p3071231.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>



-- 
Stan Lewis
FuseSource
Email: slewis@fusesource.com
Web: http://fusesource.com
Twitter: gashcrumb

Mime
View raw message