activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oscar Pernas <os...@pernas.es>
Subject ACTIVEMQ-CPP. Topic consumer after connection interrupt and restore
Date Fri, 03 Dec 2010 13:06:47 GMT
Hi all,

Sorry if I'am missunderstanding something but I have a activemq-cpp topic
consumer. I am trying to test connection interrupt and restores, and how
messages are sent to a durable topic. To do this, I've put a breakpoint in
my code after connect to broker. Some time later, I've press to continue
executing the program and I receive a connection interrupt and a connection
restore like this:


- Created consumer, and received two messages:

2010-12-03 13:48:53 DEBUG (ActiveConsumer:202) - ActiveConsumer::run.
Consumer is started succesfully: 1
2010-12-03 13:48:53 INFO  (ActiveManager:1076) - Started connection id 1
succesfully.
Message received: 0 from connection 2FIPASO1111116E0
Message received: 0 from connection 2FIPASO1111116E1


Stopped by the breakpoint and received interrupt and restore:


2010-12-03 14:00:27 DEBUG (ActiveConsumer:559) -
Producer::transportInterrupted. The Connection's Transport has been
interrupted.consumer1
ERROR: Received on onConnectionInterrupted from 1
2010-12-03 14:00:27 DEBUG (ActiveConsumer:577) - Producer::transportResumed.
The Connection's Transport has been Restored.consumer1
ERROR: Received on onConnectionRestore from 1


But after that, I can't receive any message by this topic, It could be a bad
test making a breakpoint, but I'm trying to understand. Any clue?


regards


-- 
Óscar Pernas Plaza.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message