activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From alikic <ali...@rogers.com>
Subject Re: Problem using Ajax to listen to a queue/topic
Date Wed, 29 Dec 2010 16:23:12 GMT

Update: HTTP request/response, as reported by Safari's Web Inspector:

1. Initial addListener() call:
--------------------------
Request URL:http://localhost:8161/amq/amq
Request Method:POST
Status Code:200 OK

Request Headers
Cache-Control:max-age=0
Content-Type:application/x-www-form-urlencoded; charset=UTF-8
Origin:http://localhost:8161
Referer:http://localhost:8161/testamq/testMq.html
User-Agent:Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US)
AppleWebKit/533.19.4 (KHTML, like Gecko) Version/5.0.3 Safari/533.19.4
X-Requested-With:XMLHttpRequest

Form Data
destination:queue://qTest
message:testMq
type:listen
clientId:1293638942802

Response Headers
Cache-Control:no-cache
Content-Length:0
Content-Type:text/plain;charset=ISO-8859-1
Server:Jetty(7.1.6.v20100715)

2. Subsequent calls:
------------------------------------
Request URL:http://localhost:8161/amq/amq?_dc=1293638942804
Request Method:GET
Status Code:200 OK

Request Headers
Cache-Control:max-age=0
Content-Type:text/plain
Referer:http://localhost:8161/testamq/testMq.html
User-Agent:Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US)
AppleWebKit/533.19.4 (KHTML, like Gecko) Version/5.0.3 Safari/533.19.4
X-Requested-With:XMLHttpRequest

Response Headers
Cache-Control:no-cache
Content-Length:35
Content-Type:text/xml;charset=ISO-8859-1
Server:Jetty(7.1.6.v20100715)

NOTE1: Web Inspector console is clean - no errors/warnings.
NOTE2: The GET calls get the following content from the server, every 25
seconds:
<ajax-response>
</ajax-response>

-- 
View this message in context: http://activemq.2283324.n4.nabble.com/Problem-using-Ajax-to-listen-to-a-queue-topic-tp3167287p3167318.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message