activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From stratio <stra...@hotmail.it>
Subject Re: Problem with Ajax API
Date Wed, 22 Dec 2010 11:32:51 GMT

I checked the server response and this is what i get :

Headers :

Request
URL:http://localhost:8161/demo/amq?timeout=45000&d=1293017028128&r=0.2588740265928209
Request Method:GET
Status Code:200 OK
Request Headers
Accept:application/xml, text/xml, */*
Accept-Charset:ISO-8859-1,utf-8;q=0.7,*;q=0.3
Accept-Encoding:gzip,deflate,sdch
Accept-Language:it-IT,it;q=0.8,en-US;q=0.6,en;q=0.4
Connection:keep-alive
Content-Type:application/x-www-form-urlencoded
Cookie:JSESSIONID=dhspps8mjouadmjv4ycsmsp9
Host:localhost:8161
Referer:http://localhost:8161/demo/index_activeMQ.html
User-Agent:Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US)
AppleWebKit/534.10 (KHTML, like Gecko) Chrome/8.0.552.224 Safari/534.10
X-Requested-With:XMLHttpRequest
Query String Parameters
timeout:45000
d:1293017028128
r:0.2588740265928209
Response Headers
Cache-Control:no-cache
Content-Length:104
Content-Type:text/xml;charset=ISO-8859-1
Server:Jetty(7.1.6.v20100715)


Content :

<ajax-response>
<response id='test' destination='topic://ActiveMQFeed' ></response>
</ajax-response>




So I guess that the reason for which i don't see anything on the browser is
that the response is a binary message. I saw this
https://issues.apache.org/jira/browse/AMQ-2833 about this problem
(considering i'm publishing the messages on the topic via a stomp ruby
client).

How can I apply the patch in order to solve the problem?
Do I have to modify the Javascript code?

Thanks again :)

-- 
View this message in context: http://activemq.2283324.n4.nabble.com/Problem-with-Ajax-API-tp3155676p3160494.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message