activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert.Sloss@Misys.com" <Robert.Sl...@Misys.com>
Subject Re: Slow throughput after several hundred messages
Date Mon, 13 Dec 2010 12:27:21 GMT

I have attached a compressed rar file containing the broker debug trace: 

http://activemq.2283324.n4.nabble.com/file/n3085354/logs.rar logs.rar 

Due to attachment file size limits, I will attempt in separate posts to add
the broker configuration and crude netbeans project I used to show this
behaviour as well as some heap dumps of the jvm before, during and after
running the test project. 

Again the only obvious exception being logged is this EOFException:

2010-12-13 12:03:07,203 | DEBUG | Transport failed: java.io.EOFException |
org.apache.activemq.broker.TransportConnection.Transport | ActiveMQ
Transport: tcp:///10.113.32.88:2428
java.io.EOFException
	at java.io.DataInputStream.readInt(DataInputStream.java:375)
	at
org.apache.activemq.openwire.OpenWireFormat.unmarshal(OpenWireFormat.java:269)
	at
org.apache.activemq.transport.tcp.TcpTransport.readCommand(TcpTransport.java:227)
	at
org.apache.activemq.transport.tcp.TcpTransport.doRun(TcpTransport.java:219)
	at
org.apache.activemq.transport.tcp.TcpTransport.run(TcpTransport.java:202)
	at java.lang.Thread.run(Thread.java:619)
-- 
View this message in context: http://activemq.2283324.n4.nabble.com/Slow-throughput-after-several-hundred-messages-tp3082431p3085354.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message