activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From benoitx <beno...@yahoo.com>
Subject Re: [5.4.2] New XML config issue? Not backward compatible?
Date Tue, 07 Dec 2010 00:22:19 GMT

Sorry to come back on this... When we set this up via Spring XML, the
validate=false does not seem to work:


    <bean id="amqConnectionFactory"
class="org.apache.activemq.ActiveMQConnectionFactory">
        <constructor-arg
value="vm://localhost?brokerConfig=xbean:appendium-esb-server-activemq-broker-config.xml?validate=false"
/>
        <property name="redeliveryPolicy">
            <bean class="org.apache.activemq.RedeliveryPolicy">
                <!-- assuming one re-try per second this amounts to 24 hours
-->
                <property name="maximumRedeliveries" value="86400" />
            </bean>
        </property>
    </bean>

we seem to get this:


2010-12-07 00:17:29,558 ERROR [notifiers.ConnectNotifier#?]
(WrapperListener_start_runner:) Failed to connect/reconnect:
ActiveMQJmsConnector{this=3d31f2b4, started=false, initialised=true,
name='Ap_jmsConnector', disposed=false,
numberOfConcurrentTransactedReceivers=4,
createMultipleTransactedReceivers=true, connected=false,
supportedProtocols=[jms], serviceOverrides=null}. Root Exception was:
Invalid connect parameters: {validate=false}. Type: class
java.lang.IllegalArgumentException

Any suggestion welcome...

Thanks!

Benoit
-- 
View this message in context: http://activemq.2283324.n4.nabble.com/5-4-2-New-XML-config-issue-Not-backward-compatible-tp3075377p3075590.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message