activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guillaume HERAIL <guillaume.her...@gmail.com>
Subject Re: Multiple network interfaces and multicast
Date Thu, 25 Nov 2010 17:30:01 GMT
Is multicast://default?joinNetworkInterface=eth1 correct ?

2010/11/24 Guillaume HERAIL <guillaume.herail@gmail.com>:
> Thanks! I'll try it
>
> 2010/11/24 Gary Tully <gary.tully@gmail.com>:
>> There are attributes for the interface used, enable trace logging for
>> the org.apache.activemq.transport.discovery.multicast.MulticastDiscoveryAgent
>> and it will output the values used and the attribute names.
>> Set the attributes via query parameters on the multicast url.
>> some detail in https://issues.apache.org/activemq/browse/AMQ-2842
>>
>> On 23 November 2010 18:01, Guillaume HERAIL <guillaume.herail@gmail.com> wrote:
>>> Hello,
>>>
>>> I have 2 servers with 2 network interfaces on them (eth0 : public
>>> interface, eth1 : vlan). I try to set up an activemq cluster via
>>> multicast. ActiveMQ doesn't bind on eth1 for multicast as netstat
>>> shows it :
>>>
>>> # netstat -g
>>> IPv6/IPv4 Group Memberships
>>> Interface       RefCnt Group
>>> --------------- ------ ---------------------
>>> lo              1      ALL-SYSTEMS.MCAST.NET
>>> eth0            2      239.255.2.3
>>> eth0            1      ALL-SYSTEMS.MCAST.NET
>>> eth1            1      ALL-SYSTEMS.MCAST.NET
>>> lo              1      ip6-allnodes
>>> eth0            1      ff02::1:ff04:bce
>>> eth0            1      ip6-allnodes
>>> eth1            1      ff02::1:ff04:bcf
>>> eth1            1      ip6-allnodes
>>> dummy0          1      ip6-allnodes
>>> tunl0           1      ip6-allnodes
>>> sit0            1      ip6-allnodes
>>>
>>> I have used activemq-dynamic-broker1.xml and modified it so it binds
>>> on the VLan IP :
>>>
>>> <transportConnectors>
>>>            <transportConnector name="openwire"
>>> uri="tcp://192.168.0.1:61616" discoveryUri="multicast://default" />
>>> </transportConnectors>
>>>
>>> How can i tell to ActiveMQ tu use eth1 for multicast ?
>>>
>>> Thanks,
>>>
>>> --
>>> Guillaume
>>>
>>
>>
>>
>> --
>> http://blog.garytully.com
>> http://fusesource.com
>>
>
>
>
> --
> Guillaume
>



-- 
Guillaume

Mime
View raw message