activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Cohen <sco...@javactivity.org>
Subject build instructions seems to be missing a step:
Date Wed, 10 Nov 2010 22:01:26 GMT

Following the instructions here:
http://activemq.apache.org/getting-started.html#GettingStarted-StartingActiveMQ

I downloaded the source to 5.4.1.  (None of the mirrors were working so 
I downloaded from svn:

svn co http://svn.apache.org/repos/asf/activemq/tags/activemq-5.4.1

I then ran

mvn clean install

tests were occasionally failing, so per instructions, I then ran

mvn clean install -Dmaven.test.skip=true

This completed successfully:


[INFO] 
------------------------------------------------------------------------
[INFO] Reactor Summary:
[INFO] 
------------------------------------------------------------------------
[INFO] ActiveMQ .............................................. SUCCESS 
[3.381s]
[INFO] ActiveMQ :: KahaDB .................................... SUCCESS 
[4.090s]
[INFO] ActiveMQ :: JAAS ...................................... SUCCESS 
[1.938s]
[INFO] Openwire Generator .................................... SUCCESS 
[2.472s]
[INFO] ActiveMQ :: jmdns 1.0 ................................. SUCCESS 
[2.061s]
[INFO] ActiveMQ :: Core ...................................... SUCCESS 
[50.138s]
[INFO] ActiveMQ :: RA ........................................ SUCCESS 
[18.712s]
[INFO] ActiveMQ :: Pool ...................................... SUCCESS 
[12.692s]
[INFO] ActiveMQ :: Camel ..................................... SUCCESS 
[13.922s]
[INFO] ActiveMQ :: Console ................................... SUCCESS 
[3.452s]
[INFO] ActiveMQ :: Optional .................................. SUCCESS 
[1:05.453s]
[INFO] ActiveMQ :: Jar Bundle ................................ SUCCESS 
[9.631s]
[INFO] ActiveMQ :: File Server ............................... SUCCESS 
[20.016s]
[INFO] ActiveMQ :: Blueprint ................................. SUCCESS 
[28.424s]
[INFO] ActiveMQ :: Apache Karaf .............................. SUCCESS 
[9.394s]
[INFO] ActiveMQ :: RAR ....................................... SUCCESS 
[6.473s]
[INFO] ActiveMQ :: Run Jar ................................... SUCCESS 
[0.638s]
[INFO] ActiveMQ :: Spring .................................... SUCCESS 
[7.612s]
[INFO] ActiveMQ Tooling ...................................... SUCCESS 
[0.048s]
[INFO] ActiveMQ :: Memory Usage Test Plugin .................. SUCCESS 
[42.050s]
[INFO] ActiveMQ :: Performance Test Plugin ................... SUCCESS 
[2.183s]
[INFO] ActiveMQ :: StartUp Plugin ............................ SUCCESS 
[8.567s]
[INFO] ActiveMQ :: Web ....................................... SUCCESS 
[9.027s]
[INFO] ActiveMQ :: Web Demo .................................. SUCCESS 
[2.446s]
[INFO] ActiveMQ :: XMPP ...................................... SUCCESS 
[39.770s]
[INFO] ActiveMQ :: Web Console ............................... SUCCESS 
[16.565s]
[INFO] ActiveMQ :: Assembly .................................. SUCCESS 
[3:30.142s]
[INFO] 
------------------------------------------------------------------------
[INFO] 
------------------------------------------------------------------------
[INFO] BUILD SUCCESSFUL
[INFO] 
------------------------------------------------------------------------
[INFO] Total time: 9 minutes 53 seconds
[INFO] Finished at: Wed Nov 10 15:38:38 CST 2010
[INFO] Final Memory: 75M/323M
[INFO] 
------------------------------------------------------------------------

I am next directed here:
http://activemq.apache.org/getting-started.html#GettingStarted-StartingActiveMQ

After cding to the activemq install dir i.e., the directory from which I 
launched mvn, I am instructed to invoke

bin\activemq

But there is no bin directory here.


Mime
View raw message