activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bobby Richards <bobby.richa...@gmail.com>
Subject Re: websockets in 5.4.0: Anyone got the clients working ? ...
Date Tue, 12 Oct 2010 18:40:30 GMT
Dejan,

Is there any kind of to do list with regard to web sockets?

Thanks,
Bobby

On Thu, Oct 7, 2010 at 4:50 AM, Dejan Bosanac <dejan@nighttale.net> wrote:
> Hi Ravi,
>
> just tried the original demo and it seems it doesn't work. Can you
> raise a Jira issue for this?
>
> Cheers
> --
> Dejan Bosanac - http://twitter.com/dejanb
>
> Open Source Integration - http://fusesource.com/
> ActiveMQ in Action - http://www.manning.com/snyder/
> Blog - http://www.nighttale.net
>
>
>
> On Wed, Oct 6, 2010 at 9:35 PM, Ravi <extsknk@gmail.com> wrote:
>> Dejan
>>
>> any updates ?  WebSockets was an attractive feature we were hoping to use
>> easily.
>>
>> Thank you so much.
>>
>> On Mon, Sep 20, 2010 at 12:03 AM, Dejan Bosanac <dejan@nighttale.net> wrote:
>>
>>> Hi Ravi,
>>>
>>> it worked for me at the time I created it.
>>>
>>> I'll revisit it again soon and see to integrate some clients with
>>> tests, so we make sure everything works in the future.
>>>
>>>
>>> Cheers
>>> --
>>> Dejan Bosanac - http://twitter.com/dejanb
>>>
>>> Open Source Integration - http://fusesource.com/
>>> ActiveMQ in Action - http://www.manning.com/snyder/
>>> Blog - http://www.nighttale.net
>>>
>>>
>>>
>>> On Mon, Sep 20, 2010 at 4:16 AM, Ravi <extsknk@gmail.com> wrote:
>>> > Anyone ?
>>> >
>>> > On Thu, Sep 16, 2010 at 2:19 PM, Ravi <extsknk@gmail.com> wrote:
>>> >
>>> >>
>>> >>
>>> >> browser: Chrome   OS: Ubuntu 10.4
>>> >>
>>> >> I followed the instructions for both stomple & stomp-websockets
(Clients
>>> >> section http://activemq.apache.org/websockets.html)
>>> >> There is no indication either one can connect to the broker
>>> successfully.
>>> >>
>>> >> Anyone got either of them working ? What's the sauce I am missing ?
>>> >>
>>> >> stomp-websockets (
>>> >>
>>> http://www.nighttale.net/activemq/activemq-54-stomp-over-web-sockets.html)
>>> >> --------------------------
>>> >>
>>> >> It says 'Opening web socket' and just hangs
>>> >>
>>> >> stomple  (followed instructions like above and pointed browser to
>>> >>  demo/stomple/test/all.html)
>>> >> -----------
>>> >>
>>> >> Almost all the tests that need successful connection fail. In activemq
>>> log
>>> >> I see ...
>>> >>
>>> >> ERROR | handle failed?
>>> >> java.lang.IllegalArgumentException: !utf8
>>> >>  at
>>> >>
>>> org.eclipse.jetty.util.Utf8StringBuilder.append(Utf8StringBuilder.java:122)
>>> >> at
>>> >>
>>> org.eclipse.jetty.websocket.WebSocketParser.parseNext(WebSocketParser.java:147)
>>> >>  at
>>> >>
>>> org.eclipse.jetty.websocket.WebSocketConnection.handle(WebSocketConnection.java:75)
>>> >> at
>>> >>
>>> org.eclipse.jetty.server.bio.SocketConnector$ConnectorEndPoint.run(SocketConnector.java:252)
>>> >>  at
>>> >>
>>> org.eclipse.jetty.util.thread.QueuedThreadPool$2.run(QueuedThreadPool.java:436)
>>> >> at java.lang.Thread.run(Thread.java:619)
>>> >>
>>> >>
>>> >
>>>
>>
>

Mime
View raw message