activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dirk Fröhner <dirk.froeh...@email.de>
Subject Re: Consumers are hanging and not receiving messages
Date Fri, 29 Oct 2010 11:39:42 GMT
Hi devnull,

did you make sure that your Java consumers do eventually ACK messages (i.e. is it ensured
that onMessage() does always return)? You should also have a look at the subscription properties
on that destination in jconsole.

Glück auf,
Dirk

On Oct 28, 2010, at 12:09 AM, devnull wrote:

> 
> hi all, 
> I have a producer and 4 consumer threads going to a single queue. The
> producer and consumer are on different machines. After the consumer pulls
> down 1950 or so messages it starts to hang. The primary consumer is in Java.
> I have written a php test client using stomp that once the hang happens on
> the java side I cannot even deqeue with the php stomp client. The queue
> currently reports 3 million+ messages in it
> 
> here is my connection factory
> http://pastebin.com/TpfV20mB
> 
> here is a screen shot of my mbeans panel in jmx
> http://www.dropmocks.com/mEI7H
> 
> I've tried restarting the server and java applications and both result in
> the same outtime. After a couple thousand dequeues nothing else will be
> dequeued from that queue. 
> 
> Anything else I can help post to debug?
> thanks
> 
> -- 
> View this message in context: http://activemq.2283324.n4.nabble.com/Consumers-are-hanging-and-not-receiving-messages-tp3016373p3016373.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message