activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jns <shahj...@yahoo.com>
Subject Re: Store percent usage not decreasing - activemq.xml settings
Date Wed, 20 Oct 2010 23:23:01 GMT

Seems xml format did not appear n previous post. This is short version of
activemq config file


        <persistenceAdapter>
		<amqPersistenceAdapter directory="activemq-data" maxFileLength="30mb" />
        </persistenceAdapter>

       <destinationPolicy>
            <policyMap>
                <policyEntries>

                    
                    <policyEntry
                       queue="xyz.channels>" 
                       producerFlowControl="false"
                       memoryLimit="100mb" >
                      
                       <deadLetterStrategy>
                           <individualDeadLetterStrategy
processExpired="false" />
                       </deadLetterStrategy>
                    </policyEntry>
                    
                    
                    <policyEntry 
                        topic="topic1" 
                        producerFlowControl="false"  >

                        <dispatchPolicy>
                            <strictOrderDispatchPolicy />
                        </dispatchPolicy>
                        <subscriptionRecoveryPolicy>
                            <fixedSizedSubscriptionRecoveryPolicy
maximumSize="1000" />
                        </subscriptionRecoveryPolicy>
                    </policyEntry>

                </policyEntries>
            </policyMap>
        </destinationPolicy>

        <!-- Use the following to configure how ActiveMQ is exposed in JMX
-->
        <managementContext>
            <managementContext 
                connectorPort="1099" 
                jmxDomainName="org.apache.activemq" 
                createConnector="true" />
        </managementContext>
      
        <!--  The maximum amount of space the broker will use before slowing
down producers -->
        <systemUsage>
            <systemUsage sendFailIfNoSpace="true">
                <memoryUsage>
                    <memoryUsage limit="350 mb" percentUsageMinDelta="20" />
                </memoryUsage>
                <storeUsage>
                    <storeUsage limit="2 gb" name="foo"/>
                </storeUsage>
                <tempUsage>
                    <tempUsage limit="500 mb"/>
                </tempUsage>
            </systemUsage>
        </systemUsage>

        <!-- The transport connectors ActiveMQ will listen to -->
        <transportConnectors>
            <transportConnector name="openwire" uri="tcp://0.0.0.0:61616"/>
            <!-- Uncomment to enable SSL connections
            <transportConnector name="ssl" uri="ssl://0.0.0.0:61617"/>
            -->
        </transportConnectors>

    </broker>

-- 
View this message in context: http://activemq.2283324.n4.nabble.com/Store-percent-usage-not-decreasing-activemq-xml-settings-tp3004796p3004799.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message