activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From balrajk <balraj.kan...@alcatel-lucent.com>
Subject Master-Slave Failure with ActiveMQ 5.4.1 & JBoss 5.1
Date Wed, 20 Oct 2010 13:09:11 GMT

Hello,

I am trying to setup the master-slave configuration with ApacheMQ as JMS
broker in JBoss 5.1.
when the producer drops any message on to the queue there is exception
thrown on the master and slave servers. 
I see that fail-over happens when master goes down and also no messages are
lost. Not sure why this exception occurs, the stack trace is as below:

Master setup:

15:07:07,734 ERROR [MasterBroker] Slave Failed
java.lang.IllegalStateException: Cannot lookup a connection that had not
been registered: ID:MB1098-2096-1287480881578-4:0
        at
org.apache.activemq.broker.MapTransportConnectionStateRegister.lookupConnectionState(MapTransportConnectionStateRegister.java:93)
        at
org.apache.activemq.broker.TransportConnection.lookupConnectionState(TransportConnection.java:1412)
        at
org.apache.activemq.broker.TransportConnection.processCommitTransactionOnePhase(TransportConnection.java:419)
        at
org.apache.activemq.command.TransactionInfo.visit(TransactionInfo.java:100)
        at
org.apache.activemq.broker.TransportConnection.service(TransportConnection.java:309)

(Stack truncated....)


Slave:
15:08:29,937 WARN  [Service] Async error occurred:
java.lang.IllegalStateException: Cannot lookup a connection that had not
been registered: ID:MB1098-2096-1287480881578-4:0
java.lang.IllegalStateException: Cannot lookup a connection that had not
been registered: ID:MB1098-2096-1287480881578-4:0
        at
org.apache.activemq.broker.MapTransportConnectionStateRegister.lookupConnectionState(MapTransportConnectionStateRegister.java:93)
        at
org.apache.activemq.broker.TransportConnection.lookupConnectionState(TransportConnection.java:1412)

(Stack truncated....)


I had seen a similar post in which it states that the problem has been fixed
in 5.1 but I see this happening in 5.4.1

Please let me know if you need more details on this issue.



Regards
Balraj
-- 
View this message in context: http://activemq.2283324.n4.nabble.com/Master-Slave-Failure-with-ActiveMQ-5-4-1-JBoss-5-1-tp3003817p3003817.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message