activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From dcheckoway <dchecko...@gmail.com>
Subject Performance issue with Camel multicast in 5.4.1
Date Tue, 05 Oct 2010 19:40:58 GMT

In the process of upgrading from 5.3.2 to 5.4.1, I've encountered a new,
major performance issue.  I make use of Camel's multicast in order to
replicate messages from one queue out to four other queues...snippet from
conf/camel.xml:

        <route>
          <from uri="activemq:queue:dan.main?concurrentConsumers=5"/>
          <multicast stopOnException="true">
            <to uri="activemq:queue:dan.a"/>
            <to uri="activemq:queue:dan.b"/>
            <to uri="activemq:queue:dan.c"/>
            <to uri="activemq:queue:dan.d"/>
          </multicast>
        </route>

In 5.3.2, the multicast happened pretty much instantaneously, even with very
high producer rates.  As soon as a message was queued on "dan.main" it would
show up on the other 4 queues.  The "dan.main" queue size would hover near
zero.

In 5.4.1, the multicast is extremely slow!

My configuration is bone stock with the exception of producerFlowControl
being disabled on queues in activemq.xml:

                <policyEntry queue=">" producerFlowControl="false"
memoryLimit="1mb">

That is literally the ONLY change from the stock distribution config (other
than camel.xml being uncommented in activemq.xml in 5.3.2...whereas it's
sucked in automatically in 5.4.1).

Any ideas on what could be happening?  Is there some sort of tuning I need
to do in 5.4.1 in order to make the multicast perform as quickly as it did
in 5.3.2?
-- 
View this message in context: http://activemq.2283324.n4.nabble.com/Performance-issue-with-Camel-multicast-in-5-4-1-tp2956741p2956741.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message