activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jule <julian.qui...@gmail.com>
Subject Re: Beginner problem: Too many consumers on queue after browser restart...
Date Fri, 01 Oct 2010 11:47:53 GMT


Alex Dean-2 wrote:
> 
> 
>> For others facing the same problem: Meanwhile I found out that appending
>> a
>> "?ClientId=YourClientID" to the GET and POST urls (for either REST-API or
>> AJAX-API [uses REST-API]) will prevent this problem from showing up. I
>> guess
>> this will bypass the automatic id assignment by the broker (via cookie).
>> It
>> seems to work very reliably now. 
> 
> Supplying a 'clientId' URL parameter is supported in the REST interface,
> but it's not (yet) supported in the ajax interface
> (MessageListenerServlet).  I (and others at my job) have been working on a
> patch to fix this.  I think we're nearly there, but I'm hoping to get some
> feedback on the patch I attached to AMQ-2948.
> 
> If you supply a ClientID url parameter in an ajax request, do you see
> different results?  It looks to me like the current ajax code (in
> MessageListenerServlet) will just ignore this parameter, but I'm
> interested if you've seen other results.  What kind of test did you do?
> 
> 

Had more time to test today. You were right, the parameter will be ignored,
the problem persists. And for my application a refresh after the browser
restart won´t work. It remains broken with too many consumers on the queue.

I tried to apply the patch that you posted but unfortunately I can´t get it
to work: I downloaded the 5.4.1 sources, did a test build with Maven,
applied the patch ("patch" reported one error, I considered it minor and
continued) and build again -> I tried to run the broker in the
assembly/src/release/bin directory but I got the following:


Jule$ assembly/src/release/bin/activemq start
INFO: Using default configuration
(you can configure options in one of these file: /etc/default/activemq
/Users/Jule/.activemqrc)

INFO: Invoke the following command to create a configuration file
assembly/src/release/bin/activemq setup [ /etc/default/activemq |
/Users/Jule/.activemqrc ]

INFO: Using java '/System/Library/Frameworks/JavaVM.framework/Home/bin/java'
INFO: Starting - inspect logfiles specified in logging.properties and
log4j.properties to get details
ERROR:
'/Users/Jule/Downloads/activemq-parent-5.4.1/assembly/src/release/bin/run.jar'
does not exist


I guess that this error is not related to the patch mentioned. Its more
likely that I have missed something, I never compiled ActiveMQ by myself
before... If you have a hint?

-- 
View this message in context: http://activemq.2283324.n4.nabble.com/Beginner-problem-Too-many-consumers-on-queue-after-browser-restart-tp2719286p2895561.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message