activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oscar Pernas <os...@pernas.es>
Subject Re: ACTIVEMQ-CPP Error compiling activemq-cpp release SSL
Date Tue, 28 Sep 2010 10:55:18 GMT
yes sorry, I'd read somewhere that  I had to change the Version="9.00" to
Version="8.00" in vcproj to try to open project with visual 2005 ( i can't
use vs2008).. this cause the compile errors?



2010/9/28 Timothy Bish <tabish121@gmail.com>

> On Tue, 2010-09-28 at 09:59 +0100, Oscar Pernas wrote:
> > Hi all,
> >
> >
> > Im trying to compile Activemq-CPP 3.2.3. My problem is that when I try to
> > compile SSL versions, I allways get compile errors:
> >
> > ..\src\main\decaf\lang\System.cpp(389) : error C2664: 'strlen' : cannot
> > convert parameter  1 from 'LPTSTR' a 'const char *'
> > ..\src\main\decaf\lang\System.cpp(395) : error C2664:
> > 'std::vector<_Ty>::push_back' : cannot convert parameter  1 1 de 'LPTSTR'
> a
> > 'const std::string &'
> >
> >
> > any idea?
> >
>
>
> That particular bit of code hasn't changed in some time and has built
> with VS2005, VS2008 and VS2010.  Have you changed any project settings
> in the supplied VS project files?
>
> Regards
>
> --
> Tim Bish
>
> Open Source Integration: http://fusesource.com
>
> Follow me on Twitter: http://twitter.com/tabish121
> My Blog: http://timbish.blogspot.com/
>
>


-- 
Óscar Pernas Plaza.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message