activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Colleen Velo <cmv...@gmail.com>
Subject Re: Even after upgrade to ActiveMQ 5.4.0, still seeing negative #'s in the "Pending Msgs" column
Date Wed, 08 Sep 2010 14:38:15 GMT
Gary,

Forgot to add that I do see the same thing in JConsole, that is the negative
counts.

On Fri, Sep 3, 2010 at 1:37 PM, Colleen Velo <cmvelo@gmail.com> wrote:

> Gary,
>
> Thanks for the clarification - still working on a JUnit test.
> Currently right now the steps that I use to reproduce it is
> to have the 3 producers each send *60,000* messages each to
> the ActiveMQ cluster at the same time - more often than
> not, when the queue is trending down towards 0 on the
> broker(s), sometimes a negative # will appear in the "Pending Msgs"
> column (it has been frustrating because it seems to happen
> intermittently).
>
> *Current Setup:*
>
> • 3 producers
> • 3 brokers (all part of the same ActiveMQ cluster)
> • 3 consumers
> • 1 queue
>
>
> *Broker definition*:
>         • <networkConnector name="ActiveMQ Cluster"
> uri="static:(tcp://brokersvr1:61616,tcp://brokersvr2:61616,tcp://brokersvr3:61616)"
> conduitSubscriptions="false" dynamicOnly="true"
> decreaseNetworkConsumerPriority="true"
> suppressDuplicateQueueSubscriptions="true" duplex="false" networkTTL="5"/>
>
> *Client definition:*
>       •
> amq.publisher.broker.url=failover\:tcp\://brokersvr1\:61616?wireFormat.maxInactivityDuration=0&daemon=true,tcp\://brokersvr2\:61616?wireFormat.maxInactivityDuration=0&daemon=true,tcp\://brokersvr3\:61616?wireFormat.maxInactivityDuration=0&daemon=true
>
>
> Let me know if you have any more questions and I'll pass along the JUnit
> test as soon
> as I can get one to fail consistently.
>
> Thanks,
>
> --
> Colleen Velo
> email: cmvelo@gmail.com
>
>
> On Thu, Sep 2, 2010 at 2:25 AM, Gary Tully <gary.tully@gmail.com> wrote:
>
>> Some series of steps that can reproduce or in the ideal case a junit
>> test we can drop into the source.
>>
>> On Wednesday, September 1, 2010, Colleen Velo <cmvelo@gmail.com> wrote:
>> > Gary
>> > re: JConsole - don't know yet. I will try to hook JConsole up and look
>> > through that as well -
>> > currently using the bundled web admin console.
>> >
>> > As far as test case, I don't have one - just the standard message
>> traffic
>> > from
>> > our producers to our consumers (slightly less than the traffic that is
>> > running
>> > currently in our Product environment with ActiveMQ server version 5.2.0.
>> >
>> > What would you need exactly for a "test" case?
>> >
>> > Thanks,
>> >
>> > --
>> > Colleen Velo
>> > *email: cmvelo@gmail.com*
>> >
>> >
>> > On Wed, Sep 1, 2010 at 8:52 AM, Gary Tully <gary.tully@gmail.com>
>> wrote:
>> >
>> >> does jconsole show the same negative number? Do you have a test case?
>> >>
>> >> On 1 September 2010 13:52, Colleen Velo <cmvelo@gmail.com> wrote:
>> >> > After only running my 3 ActiveMQ brokers for short time, I am seeing
>> >> > negative numbers in
>> >> > the "Number of Pending Messages" column.  I started seeing this at
>> 5.3.2
>> >> > (after upgrading
>> >> > from 5.2.0) and opened and issue on it:
>> >> >            • https://issues.apache.org/activemq/browse/AMQ-2887
>> >> >
>> >> > It was recommended that I upgrade to ActiveMQ 5.4.0, which I did,
>> >> however, I
>> >> > am still
>> >> > seeing this issue.
>> >> >
>> >> > Current Environment:
>> >> > • CentOS release 5.2 (both consumers and brokers)
>> >> > • 3 ActiveMQ brokers
>> >> > • 7 consumers (across different queues)
>> >> >
>> >> >
>> >> > Thanks,
>> >> >
>> >> > --
>> >> > Colleen Velo
>> >> > email: cmvelo@gmail.com
>> >> >
>> >>
>> >>
>> >>
>> >> --
>> >> http://blog.garytully.com
>> >>
>> >> Open Source Integration
>> >> http://fusesource.com
>> >>
>> >
>>
>> --
>> http://blog.garytully.com
>>
>> Open Source Integration
>> http://fusesource.com
>>
>
>


-- 
Colleen Velo
email: cmvelo@gmail.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message