activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jule <julian.qui...@gmail.com>
Subject SUGGESTION regarding "Refused to set unsafe header 'Connection'"
Date Thu, 30 Sep 2010 22:18:50 GMT

I am using "amq.js" and "amq_jquery_adapter.js" and when I run my application
with Chrome or Safari I get the error "Refused to set unsafe header
'Connection'".

I fixed this by borrowing the following lines from the latest release of
prototype.js and putting them into amq_jquery_adapter.js", starting at line
72 of the 5.4.1 version:
if (isDefined(this.transport)){
  if (this.transport.overrideMimeType &&
  (navigator.userAgent.match(/Gecko\/(\d{4})/) || [0,2005])[1] < 2005)
    headers[ 'Connection' ] = 'close';
}

I am new to this, what can I do to get it into the next release? Any
comments on this?
		    
-- 
View this message in context: http://activemq.2283324.n4.nabble.com/SUGGESTION-regarding-Refused-to-set-unsafe-header-Connection-tp2767782p2767782.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message