activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From lesiana <andreiafoeste...@gmail.com>
Subject namespace problems with spring 3.0.3 and activemq 5.4.0
Date Fri, 17 Sep 2010 12:58:31 GMT

Hello all, 


I am currently updating a project to work with spring 3.0.3 and activemq
5.4.0 but unfortunately I ran into problems.

I get the following error:  

Caused by: org.xml.sax.SAXParseException: cvc-complex-type.2.4.c: The
matching wildcard is strict, but no declaration can be found for element
'amq:broker'.

I have search but can't figure out how to fix this. 
I am using all spring modules version 3.0.3, activemq 5.4.0 and xbean-spring
3.7.

Here is part of my conf file : 

<?xml version="1.0" encoding="UTF-8"?>
<beans xmlns="http://www.springframework.org/schema/beans"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xmlns:jms="http://www.springframework.org/schema/jms"
    xmlns:amq="http://activemq.apache.org/schema/core"
    xsi:schemaLocation=
    	"http://www.springframework.org/schema/beans
http://www.springframework.org/schema/beans/spring-beans.xsd
        http://www.springframework.org/schema/jms
http://www.springframework.org/schema/jms/spring-jms.xsd
        http://activemq.apache.org/schema/core
http://activemq.apache.org/schema/core/activemq-core.xsd">
	
	
	<amq:broker useJmx="false" persistent="false">
		<amq:transportConnectors>
			<amq:transportConnector uri="tcp://localhost:0" />
		</amq:transportConnectors>
	</amq:broker>
.....

</beans>


I hope someone can help me. Thank you in advance! 

Andreia


-- 
View this message in context: http://activemq.2283324.n4.nabble.com/namespace-problems-with-spring-3-0-3-and-activemq-5-4-0-tp2543820p2543820.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message