activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From zxekak <zxe...@gmail.com>
Subject Monitoring embedded AMQ 5.3.0 broker via JMX web console help
Date Thu, 09 Sep 2010 16:11:37 GMT

Hello,

I'm trying to monitor embedded broker with WebConsole. Both WebConsole and
application with embedded broker deployed in separate wars 
under JBoss.

Broker is set as follows:
<bean id="broker" class="org.apache.activemq.xbean.XBeanBrokerService">
   <property name="start" value="true"/>
   <property name="useJmx" value="true"/>
   <property name="persistent" value="true"/> 
</bean>

<amq:connectionFactory id="amqJMSConnectionFactory"
brokerURL="vm://localhost" />

I run WebConsole with following arguments:
-Dwebconsole.type=properties 
-Dwebconsole.jms.url=vm://localhost?create=false
-Dwebconsole.jmx.url=service:jmx:rmi:///jndi/rmi://localhost:1099/jmxrmi

WebConsole is deployed succesfully and I can navigate to Queues page and see
all my Queues list, but when I trying to browse any queue I get exception:


18:48:55,467 ERROR:    [[localhost].[/activemq-web-console-5.3.0].[jsp]] -
Servlet.service() for servlet jsp threw exception
java.io.IOException: Broker named 'localhost' does not exist.
	at
org.apache.activemq.transport.vm.VMTransportFactory.doCompositeConnect(VMTransportFactory.java:115)
	at
org.apache.activemq.transport.vm.VMTransportFactory.doConnect(VMTransportFactory.java:53)
	at
org.apache.activemq.transport.TransportFactory.doConnect(TransportFactory.java:51)
	at
org.apache.activemq.transport.TransportFactory.connect(TransportFactory.java:80)
	at
org.apache.activemq.ActiveMQConnectionFactory.createTransport(ActiveMQConnectionFactory.java:240)
	at
org.apache.activemq.ActiveMQConnectionFactory.createActiveMQConnection(ActiveMQConnectionFactory.java:255)
	at
org.apache.activemq.ActiveMQConnectionFactory.createActiveMQConnection(ActiveMQConnectionFactory.java:227)
	at
org.apache.activemq.ActiveMQConnectionFactory.createConnection(ActiveMQConnectionFactory.java:175)
	at org.apache.activemq.web.SessionPool.getConnection(SessionPool.java:43)
	at org.apache.activemq.web.SessionPool.createSession(SessionPool.java:98)
	at org.apache.activemq.web.SessionPool.borrowSession(SessionPool.java:81)
	at
org.apache.activemq.web.QueueBrowseQuery.<init>(QueueBrowseQuery.java:40)

Can you help to resolve, please?

ActiveMQ and WebConsole version is 5.3.0
JBoss version is 5.1.0

Thanks.
-- 
View this message in context: http://activemq.2283324.n4.nabble.com/Monitoring-embedded-AMQ-5-3-0-broker-via-JMX-web-console-help-tp2533157p2533157.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message