activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mjustin <michael.jus...@gmx.net>
Subject EOFException in ActiveMQ 5.4.0 stomp+nio
Date Tue, 24 Aug 2010 18:04:38 GMT

Hello,

with the default configuration activemq-stomp.xml which uses stomp+nio on
Port 61613, unit tests using BytesMessages of my Stomp client run into this
error:

2010-08-24 19:48:28,652 | INFO  | Listening for connections at:
stomp://mj-PC:61612?transport.closeAsync=false |
org.apache.activemq.transport.TransportServerThreadSupport | main
2010-08-24 19:48:28,653 | INFO  | Connector stomp Started |
org.apache.activemq.broker.TransportConnector | main
2010-08-24 19:48:28,691 | INFO  | Listening for connections at:
stomp+nio://mj-PC:61613?transport.closeAsync=false |
org.apache.activemq.transport.TransportServerThreadSupport | main
2010-08-24 19:48:28,692 | INFO  | Connector stomp+nio Started |
org.apache.activemq.broker.TransportConnector | main
2010-08-24 19:48:28,700 | INFO  | ActiveMQ JMS Message Broker (localhost,
ID:mj-PC-50664-1282672108345-0:0) started |
org.apache.activemq.broker.BrokerService | main
2010-08-24 19:48:28,890 | INFO  | Logging to
org.slf4j.impl.JCLLoggerAdapter(org.eclipse.jetty.util.log) via
org.eclipse.jetty.util.log.Slf4jLog | org.eclipse.jetty.util.log | main
2010-08-24 19:48:28,890 | INFO  | jetty-7.0.1.v20091125 |
org.eclipse.jetty.util.log | main
2010-08-24 19:48:29,752 | INFO  | ActiveMQ WebConsole initialized. |
org.apache.activemq.web.WebConsoleStarter | main
2010-08-24 19:48:30,359 | INFO  | Initializing Spring FrameworkServlet
'dispatcher' | /admin | main
2010-08-24 19:48:31,139 | INFO  | ActiveMQ Console at
http://0.0.0.0:8161/admin | org.eclipse.jetty.util.log | main
2010-08-24 19:48:32,248 | INFO  | Initializing Spring root
WebApplicationContext | /camel | main
2010-08-24 19:48:35,478 | INFO  | Connector vm://localhost Started |
org.apache.activemq.broker.TransportConnector | main
2010-08-24 19:48:37,800 | INFO  | Camel Console at http://0.0.0.0:8161/camel
| org.eclipse.jetty.util.log | main
2010-08-24 19:48:37,896 | INFO  | ActiveMQ Web Demos at
http://0.0.0.0:8161/demo | org.eclipse.jetty.util.log | main
2010-08-24 19:48:37,992 | INFO  | RESTful file access application at
http://0.0.0.0:8161/fileserver | org.eclipse.jetty.util.log | main
2010-08-24 19:48:37,998 | INFO  | Started
SelectChannelConnector@0.0.0.0:8161 | org.eclipse.jetty.util.log | main
2010-08-24 19:48:42,891 | INFO  | Transport failed: java.io.EOFException |
org.apache.activemq.broker.TransportConnection.Transport | ActiveMQ NIO
Worker
java.io.EOFException
	at
org.apache.activemq.transport.stomp.StompNIOTransport.serviceRead(StompNIOTransport.java:106)
	at
org.apache.activemq.transport.stomp.StompNIOTransport.access$000(StompNIOTransport.java:51)
	at
org.apache.activemq.transport.stomp.StompNIOTransport$1.onSelect(StompNIOTransport.java:80)
	at
org.apache.activemq.transport.nio.SelectorSelection.onSelect(SelectorSelection.java:94)
	at
org.apache.activemq.transport.nio.SelectorWorker$1.run(SelectorWorker.java:119)
	at
java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:885)
	at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
	at java.lang.Thread.run(Thread.java:619)

The client receives only the first message in the queue. I reported a
related problem as fixed in a trunk version,
https://issues.apache.org/activemq/browse/AMQ-2822 - but it looks like I
missed a later change which is now in the release version.

Regards,

-----
Michael Justin
SCJP, SCJA
betasoft - Software for Delphi™ and for the Java™ platform
http://www.mikejustin.com - http://www.betabeans.de
-- 
View this message in context: http://old.nabble.com/EOFException-in-ActiveMQ-5.4.0-stomp%2Bnio-tp29524801p29524801.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message