activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From cppdeveloper <turtle...@gmail.com>
Subject Re: connection->start() or connection->createSession() hangs when trying to connect ActiveMQ-CPP client with OpenMQ broker via STOMP
Date Thu, 12 Aug 2010 21:14:18 GMT


Timothy Bish wrote:
> 
> You can append this option to the connection URI to get the Commands
> that are sent and received logged to the console:
> 
> transport.commandTracingEnabled=true
> 
> I Don't know how to configure that on the OpenMQ side.
> 
> Regards
> 

When I did this to the ActiveMQ-CPP client, I saw the following output
before it hung: 

SEND: ConnectionInfo { commandId = 1, responseRequired = true, ConnectionId
= ID:csa-nexus-43500-1281649512267-0:0, ClientId =
ID:csa-nexus-43500-1281649512267-1:0, Password = admin, UserName = admin,
BrokerPath = NULL, BrokerMasterConnector = false, Manageable = false,
ClientMaster = false, FaultTolerant = false }

I am in the process of figuring out how to see OpenMQ's Frames
sent/received. From this, I am guessing that the connection info was sent,
and OpenMQ clearly received it and opened the connection for them, but
somehow ActiveMQ-CPP is not receiving a response, so it doesn't know it is
okay to send and thus hangs forever. 
-- 
View this message in context: http://old.nabble.com/connection-%3Estart%28%29-or-connection-%3EcreateSession%28%29-hangs-when-trying-to-connect-ActiveMQ-CPP-client-with-OpenMQ-broker-via-STOMP-tp29420657p29423353.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message