activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Tully <gary.tu...@gmail.com>
Subject Re: ActiveMQ.Advisory.Connection not forwarded in network of brokers?
Date Thu, 22 Jul 2010 08:58:21 GMT
I had a quick browse at the code and I don't see these messages
explicitly ignored, it may be best to produce a small junit tests case
that demonstrates the issue and raise a jira issue. With a test case
it should be straight forward to get to the bottom of this.

You could get some inspiration for the test from -
http://svn.apache.org/viewvc/activemq/trunk/activemq-core/src/test/java/org/apache/activemq/usecases/TwoBrokerNetworkLoadBalanceTest.java?view=markup

On 22 July 2010 08:17, Michel Van Hoof <mvhoof@thisplays2.com> wrote:
>
> Bumping this up again. I'm sorry but after numerous tests, i still cannot
> figure out why this does not work. Questions on other boards / sites have
> not been answered either. Anyone who knows the in's and out's of
> Advisory.Connection ?
>
> Michel Van Hoof wrote:
>>
>> Hi,
>>
>> We are implementing a solution where we look at advisory topics to
>> register logon and logoff of a client. This worked fine in our test setup
>> but now that we are setting up our production infrastructure, i noticed
>> that these messages are not forwarded through our network of brokers. Is
>> this correct?
>>
>> Should I set a consumer to every activemq broker we would put in the
>> network to monitor these messages ? Or work with a camel router to copy
>> the information to a queue which then can be consumed elsewhere ?
>>
>> Can i staticallyIncluded the advisory topics in the networkconnector ?
>>
>
> --
> View this message in context: http://old.nabble.com/ActiveMQ.Advisory.Connection-not-forwarded-in-network-of-brokers--tp27852378p29233916.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>



-- 
http://blog.garytully.com

Open Source Integration
http://fusesource.com

Mime
View raw message