activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Tully <gary.tu...@gmail.com>
Subject Re: build errors for activemq5.3.2
Date Fri, 23 Jul 2010 12:06:55 GMT
maven 2.2.0 and jdk 1.5 for trunk is what I am using but it is not
tied to a particluar version just that later versions may be more
particular w.r.t dependencies and properties. sorry about the
reference to 2.0.9.

same will work with 5.3.2

With eclipse and the m2plugin, be sure to add the missing generated
sources directories in /target to the project source.

What compilation error are you getting with trunk?  Possibly start
with a: mvn clean install -Dtest=0 to validate.

On 23 July 2010 12:18, codescoder <bukka.ramu@gmail.com> wrote:
>
> okay..now i have downloaded the code from trunk
> (http://svn.apache.org/repos/asf/activemq/trunk/)
> then its listing following error in eclipse..
>
> "Build errors for activemq-core;
> org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute
> goal org.apache.maven.plugins:maven-compiler-plugin:2.0.2:compile
> (default-compile) on project activemq-core: Compilation failure"
>
> i gave mvn --version in command prompt following is the out put..
>
> Apache Maven 2.0.11 (r909250; 2010-02-12 11:25:50+0530)
> Java version: 1.5.0_13
> Java home: C:\Program Files (x86)\Java\jdk1.5.0_13\jre
> Default locale: en_US, platform encoding: Cp1252
> OS name: "windows 2003" version: "5.2" arch: "x86" Family: "windows"
>
> please hep me..what version of mvn and java i need to use for running code
> from trunk ..
> also please tell me for activemq5.3.2 mvn version and java version.
>
>
>
> Gary Tully wrote:
>>
>> It looks like the maven version you are using is more picky than that
>> which was used for the development of 5.3.2, those discrepancies have
>> been resolved on trunk for a large part.
>>
>> I guess you have a few options, use something like mvn 2.0.9 or use
>> trunk or patch your checkout of 5.3.2 with the fixes from trunk.
>>
>> If you move to trunk and find such issues, please open a jira issue
>> and we will get them resolved pronto.
>>
>> On 23 July 2010 11:49, codescoder <bukka.ramu@gmail.com> wrote:
>>>
>>>  using pointing the m2eclipseplugin import capability at the projects
>>> i am getting following error..
>>>
>>> [ERROR]
>>> 'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)'
>>> must be unique: activesoap:jaxp-api:jar -> duplicate declaration of
>>> version
>>> 1.3 @ org.apache.activemq:activemq-parent:5.3.2, C:\ACTIVEMQ5.3.2\pom.xml
>>>
>>>
>>> like this i am getting error for other components also eg.active
>>>
>>>
>>> Gary Tully wrote:
>>>>
>>>> rather than mvn eclipse:eclipse, I find that pointing the m2eclipse
>>>> plugin import capability at the projects works well.
>>>> There are a few caveats - the generated sources from protobuf in
>>>> activemq-core/target/generated-source need to be manually included to
>>>> the project source list (there is an add to source list in the
>>>> resource view iirc) as is the case for the parser generated selector
>>>> code.
>>>> Otherwise it works as expected
>>>>
>>>> On 23 July 2010 10:57, codescoder <bukka.ramu@gmail.com> wrote:
>>>>>
>>>>> if i add the jar files manually its working fine..
>>>>> do i need to do any other settings rather than manually adding jars to
>>>>> the
>>>>> path.
>>>>>
>>>>> codescoder wrote:
>>>>>>
>>>>>> Hi,
>>>>>> i downloaded the code from
>>>>>> http://svn.apache.org/repos/asf/activemq/tags/activemq-parent-5.3.2
>>>>>> and given following commands
>>>>>> 1) mvn clean install -Dmaven.test.skip=true -- no error its success.
>>>>>> 2) mvn clean install -- success with out any errors.
>>>>>> 3) mvn eclipse:eclipse
>>>>>> ..then i have imported the project into eclipse ,
>>>>>> then its gave me lot of errors most of them are for jar file missing.
>>>>>> its not picking from /user/.m2/repository/.. is there any other
>>>>>> settings
>>>>>> i
>>>>>> have to do it after importing the project into eclipse.(i have maven
>>>>>> eclipse plugin installed ready)
>>>>>> can you please give the list of the steps i have to do it for running
>>>>>> it
>>>>>> from eclipse..
>>>>>> thank you in advance.
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>
>>>>> --
>>>>> View this message in context:
>>>>> http://old.nabble.com/build-errors-for-activemq5.3.2-tp29245618p29245787.html
>>>>> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>>>>>
>>>>>
>>>>
>>>>
>>>>
>>>> --
>>>> http://blog.garytully.com
>>>>
>>>> Open Source Integration
>>>> http://fusesource.com
>>>>
>>>>
>>>
>>>
>>>
>>> --
>>> View this message in context:
>>> http://old.nabble.com/build-errors-for-activemq5.3.2-tp29245618p29246207.html
>>> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>>>
>>>
>>
>>
>>
>> --
>> http://blog.garytully.com
>>
>> Open Source Integration
>> http://fusesource.com
>>
>>
>
> --
> View this message in context: http://old.nabble.com/build-errors-for-activemq5.3.2-tp29245618p29246446.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>



-- 
http://blog.garytully.com

Open Source Integration
http://fusesource.com

Mime
View raw message