activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Tully <gary.tu...@gmail.com>
Subject Re: Storage utilisation not decreasing when memory utilisation reaches 70%
Date Fri, 23 Jul 2010 15:14:08 GMT
Is the advice from https://issues.apache.org/activemq/browse/AMQ-2834
relevant to your use case?

On 23 July 2010 15:32, Pavel Moravec <pavel.moravec@acision.com> wrote:
>
> Hello,
> we experience the following problem when using Active-MQ 5.3.2 for
> forwarding persistent messages.
>
> Time to time, consumers don't read mails from Active-MQ sufficiently fast so
> memory utilisation reaches 70%. Further mails are stored on disk and storage
> utilisation is growing. Once consumers are ready again, all the stored
> emails both from memory and disk are consumed. However, storage utilisation
> does not drop back to zero.
>
> Repeating the scenario above, I finished with (almost) no email in memory or
> in storage while storage usage is 100%. Active-MQ is not accepting new mails
> while it is not feeding consumers having nothing inside. A restart resolves
> the problem.
>
> Can't be there something wrong with the storage utilisation counter? Has
> somebody met the same issue already?
>
> Thanks in advance for a feedback.
> --
> View this message in context: http://old.nabble.com/Storage-utilisation-not-decreasing-when-memory-utilisation-reaches-70--tp29248087p29248087.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>



-- 
http://blog.garytully.com

Open Source Integration
http://fusesource.com

Mime
View raw message