activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From honno <hon...@163.com>
Subject Re: Having Duplicate message when using failover and networkConnector .
Date Tue, 27 Jul 2010 02:45:46 GMT

I use the same test case to test the 5.4-SNAPSHOT and the 5.3.3-SNAPSHOT
which both have the duplicate message.

So it maybe a bug in the version 5.3.0 ,5.3.2,5.3.3-SNAPSHOT and
5.4-SNAPSHOT.





Gary Tully wrote:
> 
> can you try your test case against a 5.4-SNAPSHOT?
> 
> On 26 July 2010 10:47, honno <honnom@163.com> wrote:
>>
>> HI,all.
>> I use failover transport to connect to brokerA and brokerB.The brokerA
>> and
>> brokerB use a networkConnector to connect each other.
>>
>> But i found the brokerA has a duplicate message when restart brokerA or
>> brokerB.
>>
>> The test case as follow:
>>
>> (1)start brokerA,brokerB,start producer and consumer,sending 100000
>> messages
>> by producer.
>> (2)stop brokerA, restart brokerA after 5 seconds
>> (3)stop brokerB,  restart brokerB after 5 seconds
>> (4)stop brokerA, restart brokerA after 5 seconds
>> (5)stop brokerB,  restart brokerB after 5 seconds
>> (6)stop brokerA, restart brokerA after 5 seconds
>> (7)stop brokerB,  restart brokerB after 5 seconds
>>
>> After the producer sends all messages(100000),the consumer receives all
>> messages,But i find the brokerA
>> has a message which cannot be consumed by the consumer and the message is
>> a
>> duplicate message which has bean consumed by the consumer.
>>
>> When i restart the consumer or start another consumer ,the consumer or
>> the
>> another consumer will receive the duplicate messsage.
>>
>> I use the version 5.3.2 .And i find the 5.3.2 and 5.3.0 has the same
>> problem(having duplicate message),but the 5.2.0 is OK.
>>
>> So is this  a bug of ActiveMQ 5.3.2?
>>
>> the brokerA config :
>>
>>       <networkConnectors>
>>            <networkConnector uri="static:(tcp://localhost:61617)" />
>>        </networkConnectors>
>>
>> the brokerB  config :
>>       <networkConnectors>
>>            <networkConnector uri="static:(tcp://localhost:61616)" />
>>        </networkConnectors>
>>
>> the client uri :
>>    
>> failover:(tcp://localhost:61616,tcp://localhost:61617)?randomize=false
>>
>> thanks.
>> --
>> View this message in context:
>> http://old.nabble.com/Having-Duplicate-message--when-using-failover-and-networkConnector-.-tp29264762p29264762.html
>> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>>
>>
> 
> 
> 
> -- 
> http://blog.garytully.com
> 
> Open Source Integration
> http://fusesource.com
> 
> 

-- 
View this message in context: http://old.nabble.com/Having-Duplicate-message--when-using-failover-and-networkConnector-.-tp29264762p29272539.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message