activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Evan Kuhn <>
Subject CMS 3.2.1 - Trouble reading empty strings from MapMessage fields
Date Fri, 23 Jul 2010 19:08:14 GMT


I just upgraded from ActiveMQ CMS 3.1.3 to 3.2.1, and I'm having some
trouble reading
empty strings out of MapMessage fields after sending them through the
broker. When I
try to do so, MapMessage::getString() throws the exception "Unsupported Type

To explain, here's what I do:
- Open a connection with my ActiveMQ broker
- Create a MapMessage. Set two string fields, one empty, one non-empty:
  - request->setString("STR_FIELD_1", "");
  - request->setString("STR_FIELD_2", "asdf");
- Send the message to a queue
- Read the message from the queue
- Read the two string fields from the response:
  - response->getString("STR_FIELD_1", "");
  - response->getString("STR_FIELD_2", "asdf");
Reading the non-empty string field works fine. Reading the empty one,
results in the exception "Unsupported Type Conversion".

Any idea why this is happening? I did not experience this with CMS 3.1.3.

For reference, I'm using:
- CMS 3.2.1 on Windows XP
- ActiveMQ 5.3.0 and Java 1.6.0 on Red Hat Enterprise Linux Server release
5.3 (Tikanga)
- Sending messages to a queue, using persistent messaging (via KahaDB)

Here is a small C++ program I'm using to reproduce the problem:

Thank you very much for your help
- Evan Kuhn

View this message in context:
Sent from the ActiveMQ - User mailing list archive at

View raw message